aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-02 01:54:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-02 01:55:15 +0000
commit670b8e4d0a82b0b7435057a381dbb7d1904f1f94 (patch)
treef0377f680a79302875e87afb39ef4562c38716c1
parentd4c551e8f7937debd3f9cc30b15b6af7e9591d2d (diff)
downloadports-670b8e4d0a82b0b7435057a381dbb7d1904f1f94.tar.gz
ports-670b8e4d0a82b0b7435057a381dbb7d1904f1f94.zip
science/py-cirq-rigetti: New port: Cirq module to run on Rigetti quantum computers
-rw-r--r--science/Makefile1
-rw-r--r--science/py-cirq-rigetti/Makefile44
-rw-r--r--science/py-cirq-rigetti/distinfo3
-rw-r--r--science/py-cirq-rigetti/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index c403baaeabd2..7128c5246111 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -273,6 +273,7 @@
SUBDIR += py-cirq-google
SUBDIR += py-cirq-ionq
SUBDIR += py-cirq-pasqal
+ SUBDIR += py-cirq-rigetti
SUBDIR += py-coards
SUBDIR += py-dipy
SUBDIR += py-dlib
diff --git a/science/py-cirq-rigetti/Makefile b/science/py-cirq-rigetti/Makefile
new file mode 100644
index 000000000000..f62c1ba86c7f
--- /dev/null
+++ b/science/py-cirq-rigetti/Makefile
@@ -0,0 +1,44 @@
+PORTNAME= cirq-rigetti
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.15.0
+CATEGORIES= science python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Cirq module to run on Rigetti quantum computers
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cirq-core>0:science/py-cirq-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}attrs>=20.3.0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certifi>=2021.5.30:security/py-certifi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.8.1:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}h11>=0.9.0:net/py-h11@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httpcore>=0.11.1:www/py-httpcore@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httpx>=0.15.5:www/py-httpx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}idna>=2.10:dns/py-idna@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}iso8601>=0.1.14:devel/py-iso8601@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pydantic>=1.8.2:devel/py-pydantic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt1>=1.7.1:www/py-pyjwt1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyquil>=3.0.0:devel/py-pyquil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}qcs-api-client>=0.8.0:devel/py-qcs-api-client@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}retrying>=1.3.3:devel/py-retrying@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rfc3339>=6.2:devel/py-rfc3339@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rfc3986>=1.5.0:www/py-rfc3986@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.16.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sniffio>=1.2.0:devel/py-sniffio@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toml>=0.10.2:textproc/py-toml@${PY_FLAVOR}
+
+USES= python:3.8+
+USE_PYTHON= distutils autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= quantumlib
+GH_PROJECT= Cirq
+
+WRKSRC_SUBDIR= cirq-rigetti
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-cirq-rigetti/distinfo b/science/py-cirq-rigetti/distinfo
new file mode 100644
index 000000000000..d3bd7ad48370
--- /dev/null
+++ b/science/py-cirq-rigetti/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1656663951
+SHA256 (quantumlib-Cirq-v0.15.0_GH0.tar.gz) = ed2ccb9e6d0bec155ef4e71a4cfedb0309f18a1d70b12e053549446e3a604db9
+SIZE (quantumlib-Cirq-v0.15.0_GH0.tar.gz) = 8155549
diff --git a/science/py-cirq-rigetti/pkg-descr b/science/py-cirq-rigetti/pkg-descr
new file mode 100644
index 000000000000..06a4cf0b9b6b
--- /dev/null
+++ b/science/py-cirq-rigetti/pkg-descr
@@ -0,0 +1,4 @@
+cirq-ionq provides everything you'll need to run Cirq quantum algorithms
+on Rigetti quantum computers.
+
+WWW: https://github.com/quantumlib/cirq