aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 18:53:53 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-09 21:59:00 +0000
commit672e8afc5e5f66869a25b1790dac8e0f7832248b (patch)
treebfff5abbdfd0e4e7f02de026c790149ccc6f07f2
parent680bd562fcf69bee54eefbe2f126c7fd853f3655 (diff)
downloadports-672e8afc5e5f66869a25b1790dac8e0f7832248b.tar.gz
ports-672e8afc5e5f66869a25b1790dac8e0f7832248b.zip
*/qt5-*: testlib is build-dep
Two Qt5 packages, www/qt5-webkit and x11-toolkits/qt5-declarative, depended on testlib as a runtime dep, rather than a build-dep. Clean that up, so that testlib is not a dep of any Qt-based application you might care to casually install.
-rw-r--r--www/qt5-webkit/Makefile6
-rw-r--r--x11-toolkits/qt5-declarative/Makefile6
2 files changed, 6 insertions, 6 deletions
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index 83a1f16a3d0f..b2831a472319 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -1,6 +1,6 @@
PORTNAME= webkit
DISTVERSION= 5.212.0-alpha4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= https://github.com/qt${PORTNAME}/qt${PORTNAME}/releases/download/${DISTNAME}/
PKGNAMEPREFIX= qt5-
@@ -25,8 +25,8 @@ USES= bison cmake compiler:c++11-lang gnome gperf jpeg \
USE_GNOME= glib20 libxml2 libxslt
USE_PERL5= build
USE_QT= core declarative gui location network opengl printsupport \
- sensors testlib webchannel widgets \
- buildtools_build qmake_build
+ sensors webchannel widgets \
+ buildtools_build qmake_build testlib_build
USE_RUBY= yes
USE_XORG= x11 xcomposite xrender
diff --git a/x11-toolkits/qt5-declarative/Makefile b/x11-toolkits/qt5-declarative/Makefile
index 1af2b482cdca..26cc35252a37 100644
--- a/x11-toolkits/qt5-declarative/Makefile
+++ b/x11-toolkits/qt5-declarative/Makefile
@@ -1,6 +1,6 @@
PORTNAME= declarative
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
PKGNAMEPREFIX= qt5-
@@ -10,8 +10,8 @@ COMMENT= Qt declarative framework for dynamic user interfaces
USES= compiler:c++11-lang gl python:build qmake:norecursive \
qt-dist:5
USE_GL= gl
-USE_QT= core gui network sql testlib \
- widgets buildtools_build
+USE_QT= core gui network sql widgets \
+ buildtools_build testlib_build
CONFLICTS= qt5-declarative-render2d-* qt5-qml qt5-quick