aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-06-28 01:51:16 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2021-06-28 01:51:16 +0000
commit675e5f2f84da9f77a4484c062d52cd4efccedb5d (patch)
tree681fce798e8e9df269ac0c9631ef1dd6db52ac3d
parentb205cd7d913b97d0bccca256a4d4dd5d94b492c4 (diff)
downloadports-675e5f2f84da9f77a4484c062d52cd4efccedb5d.tar.gz
ports-675e5f2f84da9f77a4484c062d52cd4efccedb5d.zip
databases/firebird40-[client|server]: Clean up
- Change library version to 4 - Remove obsolete option from CONFIGURE_ARGS - Fix pkg-plist.client
-rw-r--r--databases/firebird40-server/Makefile6
-rw-r--r--databases/firebird40-server/files/patch-builds_posix_make.defaults2
-rw-r--r--databases/firebird40-server/pkg-plist.client2
3 files changed, 5 insertions, 5 deletions
diff --git a/databases/firebird40-server/Makefile b/databases/firebird40-server/Makefile
index 7a2b35a41f38..58458196a63d 100644
--- a/databases/firebird40-server/Makefile
+++ b/databases/firebird40-server/Makefile
@@ -43,8 +43,8 @@ CONFIGURE_ARGS= --prefix=${LOCALSTATEDIR} \
--with-fbtzdata=${LIBEXECDIR}/tzdata \
--with-fbsbin=${PREFIX}/sbin \
--with-fbsecure-db=${LOCALSTATEDIR} \
- --with-fbsample-db=${EXAMPLESDIR} \
- --with-fbudf=${LIBEXECDIR}/UDF
+ --with-fbsample-db=${EXAMPLESDIR}
+
CONFIGURE_ENV+= PTHREAD_LIBS="-lpthread" \
ac_cv_header_atomic_ops_h="no" \
ac_cv_lib_atomic_ops_main="no"
@@ -176,7 +176,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/gen/Release/firebird/lib/libfbclient.so.${PORTVERSION} \
${STAGEDIR}${PREFIX}/lib
- ${LN} -fs libfbclient.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfbclient.so.3
+ ${LN} -fs libfbclient.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfbclient.so.4
${LN} -fs libfbclient.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfbclient.so
@${MKDIR} ${STAGEDIR}${PREFIX}/include/firebird
diff --git a/databases/firebird40-server/files/patch-builds_posix_make.defaults b/databases/firebird40-server/files/patch-builds_posix_make.defaults
index b30b259a6848..2959d2fa028d 100644
--- a/databases/firebird40-server/files/patch-builds_posix_make.defaults
+++ b/databases/firebird40-server/files/patch-builds_posix_make.defaults
@@ -23,7 +23,7 @@
LibraryFileName=libfbclient
LibraryFullName=$(LibraryFileName).${SHRLIB_EXT}.${FirebirdVersion}
-LibrarySoName=$(LibraryFileName).${SHRLIB_EXT}.2
-+LibrarySoName=$(LibraryFileName).${SHRLIB_EXT}.3
++LibrarySoName=$(LibraryFileName).${SHRLIB_EXT}.4
LibraryBaseName=$(LibraryFileName).${SHRLIB_EXT}
LIBFIREBIRD_FULLNAME = $(LIB)/$(LibraryFullName)
diff --git a/databases/firebird40-server/pkg-plist.client b/databases/firebird40-server/pkg-plist.client
index 543e6b40637a..83fe7fc4b3ac 100644
--- a/databases/firebird40-server/pkg-plist.client
+++ b/databases/firebird40-server/pkg-plist.client
@@ -44,6 +44,6 @@ include/ibase.h
include/iberror.h
include/perf.h
lib/libfbclient.so
-lib/libfbclient.so.3
+lib/libfbclient.so.4
lib/libfbclient.so.%%FIREBIRD_VERSION%%
%%DATADIR%%/firebird.msg