aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2021-11-11 02:23:43 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2021-11-11 02:46:35 +0000
commit676fbc40c6681b804f49eec4e05c0ae9ef655728 (patch)
tree7677b7c0f847b3659b477baf2a481e7f6042c663
parent86aeb6201615351be4ddf555c19880c8eb74e176 (diff)
downloadports-676fbc40c6681b804f49eec4e05c0ae9ef655728.tar.gz
ports-676fbc40c6681b804f49eec4e05c0ae9ef655728.zip
mail/rainloop: Fix SMTP AUTH PLAIN bug
While I'm here, * Switch to DISTVERSION * Pet portclippy * Re-format Makefile with portfmt Reference: https://github.com/RainLoop/rainloop-webmail/issues/1629 PR: 257017 Reported by: pi Obtained from: https://github.com/RainLoop/rainloop-webmail/issues/1629#issuecomment-540398127 MFH: 2021Q4 (cherry picked from commit 09c2f9d63931380306f66bcbef74667502a0c4e0)
-rw-r--r--mail/rainloop-community/Makefile6
-rw-r--r--mail/rainloop/Makefile21
2 files changed, 19 insertions, 8 deletions
diff --git a/mail/rainloop-community/Makefile b/mail/rainloop-community/Makefile
index 0e0358b6f3e3..b63791cfb2f9 100644
--- a/mail/rainloop-community/Makefile
+++ b/mail/rainloop-community/Makefile
@@ -6,10 +6,10 @@ COMMENT= Modern and interactive webmail - community edition
LICENSE= AGPLv3
+CONFLICTS_INSTALL= rainloop-[0-9]*
+
MASTERDIR= ${.CURDIR}/../rainloop
-DISTINFO_FILE= ${.CURDIR}/distinfo
PLIST= ${.CURDIR}/pkg-plist
-
-CONFLICTS_INSTALL= rainloop-[0-9]*
+DISTINFO_FILE= ${.CURDIR}/distinfo
.include "${MASTERDIR}/Makefile"
diff --git a/mail/rainloop/Makefile b/mail/rainloop/Makefile
index 6aa0ac18078d..37b9010a9499 100644
--- a/mail/rainloop/Makefile
+++ b/mail/rainloop/Makefile
@@ -1,5 +1,6 @@
PORTNAME= rainloop
-PORTVERSION= 1.16.0
+DISTVERSION= 1.16.0
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= https://github.com/RainLoop/rainloop-webmail/releases/download/v${PORTVERSION}/
PKGNAMESUFFIX?= ${PHP_PKGNAMESUFFIX}
@@ -16,20 +17,30 @@ LICENSE_PERMS= auto-accept
.endif
USES= php:web,flavors zip
-NO_BUILD= yes
+USE_PHP= curl dom iconv json openssl pcre simplexml spl xml zlib
+
NO_ARCH= yes
+NO_BUILD= yes
+
NO_WRKSUBDIR= yes
-USE_PHP= curl dom iconv json openssl pcre simplexml spl xml zlib
-PLIST_SUB= VER="${PORTVERSION}" WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
+PLIST_SUB= VER="${PORTVERSION}" \
+ WWWGRP="${WWWGRP}" \
+ WWWOWN="${WWWOWN}"
+
+OPTIONS_DEFAULT= SQLITE
OPTIONS_RADIO= DB
OPTIONS_RADIO_DB= MYSQL PGSQL SQLITE
-OPTIONS_DEFAULT= SQLITE
MYSQL_USE= PHP=pdo_mysql
PGSQL_USE= PHP=pdo_pgsql
SQLITE_USE= PHP=pdo_sqlite
+post-patch:
+ ${REINPLACE_CMD} 's/__USE_SINGLE_LINE_AUTH_PLAIN_COMMAND = false/__USE_SINGLE_LINE_AUTH_PLAIN_COMMAND = true/' \
+ ${WRKSRC}/rainloop/v/${PORTVERSION}/app/libraries/MailSo/Smtp/SmtpClient.php
+ ${RM} ${WRKSRC}/rainloop/v/${PORTVERSION}/app/libraries/MailSo/Smtp/SmtpClient.php.bak
+
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}/data
${INSTALL_DATA} ${WRKSRC}/data/* ${STAGEDIR}${WWWDIR}/data