aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 15:47:44 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-14 16:09:34 +0000
commit677c60e217735e19a2dd2748e4cca8e40617070d (patch)
tree0bf0086ed56cc9bdfba116764e9029bbdccb94e3
parentfcaa4af1213774cf14051ee53b94b6c68c9e7351 (diff)
downloadports-677c60e217735e19a2dd2748e4cca8e40617070d.tar.gz
ports-677c60e217735e19a2dd2748e4cca8e40617070d.zip
net/gupnp-tools: Add gupnp-tools 0.10.1
GUPnP is an object-oriented open source framework for creating UPnP devices and control points, written in C using GObject and libsoup. The GUPnP API is intended to be easy to use, efficient and flexible. GUPnP Tools are free replacements of Intel UPnP tools that use GUPnP. They provides the following client and server side tools which enable one to easily test and debug one's UPnP devices and control points: - Universal Control Point: a tool that enables one to discover UPnP devices and services, retrieve information about them, subscribe to events and invoke actions. - Network Light: a virtual light bulb that allows control points to switch it on and off, change its dimming level and query its current status. It also provides a simple UI to control all the network lights available on the network. - AV Control Point: a simple media player UI that enables one to discover and play multimedia contents available on a network. It is strictly a control point and therefore does not have any playback capabilities of it's own and relies on external UPnP MediaRenderer devices for actual playback. - Upload: a simple commandline utility that uploads files to known MediaServers. Use Universal Control Point for discovering the MediaServers. WWW: https://wiki.gnome.org/Projects/GUPnP WWW: https://gitlab.gnome.org/GNOME/gupnp-tools
-rw-r--r--net/Makefile1
-rw-r--r--net/gupnp-tools/Makefile35
-rw-r--r--net/gupnp-tools/distinfo3
-rw-r--r--net/gupnp-tools/pkg-descr23
-rw-r--r--net/gupnp-tools/pkg-plist23
5 files changed, 85 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8c6f797407df..c27e8144b9fd 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -226,6 +226,7 @@
SUBDIR += gupnp-av
SUBDIR += gupnp-dlna
SUBDIR += gupnp-igd
+ SUBDIR += gupnp-tools
SUBDIR += gupnp-ui
SUBDIR += gutenfetch
SUBDIR += gwhois
diff --git a/net/gupnp-tools/Makefile b/net/gupnp-tools/Makefile
new file mode 100644
index 000000000000..9d996d2aef7c
--- /dev/null
+++ b/net/gupnp-tools/Makefile
@@ -0,0 +1,35 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= gupnp-tools
+PORTVERSION= 0.10.1
+CATEGORIES= net
+MASTER_SITES= GNOME
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Set of utilities and demos to work with UPnP
+
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= glib>=2.24:devel/glib20 \
+ gssdp>=1.2.0:net/gssdp \
+ gtk3>=3.10:x11-toolkits/gtk30 \
+ gupnp>=1.2.0:net/gupnp \
+ libsoup>=2.42:devel/libsoup
+LIB_DEPENDS= libgssdp-1.2.so:net/gssdp \
+ libgupnp-1.2.so:net/gupnp \
+ libsoup-2.4.so:devel/libsoup
+
+USES= gnome meson pkgconfig tar:xz
+USE_GNOME= glib20 gtk30 libxml2
+
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= AV_TOOLS
+OPTIONS_DEFAULT=AV_TOOLS
+
+AV_TOOLS_MESON_TRUE= av-tools
+AV_TOOLS_BUILD_DEPENDS= gupnp-av>=0.5.5:net/gupnp-av
+AV_TOOLS_LIB_DEPENDS= libgupnp-av-1.0.so:net/gupnp-av
+
+.include <bsd.port.mk>
diff --git a/net/gupnp-tools/distinfo b/net/gupnp-tools/distinfo
new file mode 100644
index 000000000000..1bae5eef7d2c
--- /dev/null
+++ b/net/gupnp-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625585420
+SHA256 (gupnp-tools-0.10.1.tar.xz) = 4ea96d167462b3a548efc4fc4ea089fe518d7d29be349d1cce8982b9ffb53b4a
+SIZE (gupnp-tools-0.10.1.tar.xz) = 178164
diff --git a/net/gupnp-tools/pkg-descr b/net/gupnp-tools/pkg-descr
new file mode 100644
index 000000000000..d37917a1a252
--- /dev/null
+++ b/net/gupnp-tools/pkg-descr
@@ -0,0 +1,23 @@
+GUPnP is an object-oriented open source framework for creating UPnP devices and
+control points, written in C using GObject and libsoup. The GUPnP API is
+intended to be easy to use, efficient and flexible.
+
+GUPnP Tools are free replacements of Intel UPnP tools that use GUPnP. They
+provides the following client and server side tools which enable one to easily
+test and debug one's UPnP devices and control points:
+- Universal Control Point: a tool that enables one to discover UPnP devices and
+ services, retrieve information about them, subscribe to events and invoke
+ actions.
+- Network Light: a virtual light bulb that allows control points to switch it on
+ and off, change its dimming level and query its current status. It also
+ provides a simple UI to control all the network lights available on the
+ network.
+- AV Control Point: a simple media player UI that enables one to discover and
+ play multimedia contents available on a network. It is strictly a control
+ point and therefore does not have any playback capabilities of it's own and
+ relies on external UPnP MediaRenderer devices for actual playback.
+- Upload: a simple commandline utility that uploads files to known MediaServers.
+ Use Universal Control Point for discovering the MediaServers.
+
+WWW: https://wiki.gnome.org/Projects/GUPnP
+WWW: https://gitlab.gnome.org/GNOME/gupnp-tools
diff --git a/net/gupnp-tools/pkg-plist b/net/gupnp-tools/pkg-plist
new file mode 100644
index 000000000000..eeb4a072987c
--- /dev/null
+++ b/net/gupnp-tools/pkg-plist
@@ -0,0 +1,23 @@
+bin/gssdp-discover
+bin/gupnp-av-cp
+bin/gupnp-network-light
+bin/gupnp-universal-cp
+bin/gupnp-upload
+%%DATADIR%%/pixmaps/media-renderer.png
+%%DATADIR%%/pixmaps/network-light-22x22.png
+%%DATADIR%%/pixmaps/network-light-off.png
+%%DATADIR%%/pixmaps/network-light-on.png
+%%DATADIR%%/pixmaps/upnp-action-arg-in.png
+%%DATADIR%%/pixmaps/upnp-action-arg-out.png
+%%DATADIR%%/pixmaps/upnp-device.png
+%%DATADIR%%/pixmaps/upnp-service.png
+%%DATADIR%%/pixmaps/upnp-state-variable.png
+%%DATADIR%%/xml/Dimming-scpd.xml
+%%DATADIR%%/xml/SwitchPower-scpd.xml
+%%DATADIR%%/xml/network-light-desc.xml
+share/icons/hicolor/256x256/apps/av-cp.png
+share/icons/hicolor/256x256/apps/network-light.png
+share/icons/hicolor/256x256/apps/universal-cp.png
+share/icons/hicolor/64x64/apps/av-cp.png
+share/icons/hicolor/64x64/apps/network-light.png
+share/icons/hicolor/64x64/apps/universal-cp.png