aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Herschke <lhersch@dssgmbh.de>2024-03-22 20:30:22 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-03-22 20:30:22 +0000
commit6832fb6ba42f365f83bf04e2d832d1a6ba16749a (patch)
tree2e6cfc52328caf53c813d4b4a654b5194ad0d857
parent4ae57550eff8ceec265401f37a1fa738d0b73bc1 (diff)
downloadports-6832fb6ba42f365f83bf04e2d832d1a6ba16749a.tar.gz
ports-6832fb6ba42f365f83bf04e2d832d1a6ba16749a.zip
deskutils/kdeconnect-kde: fix broken patch for the sftp_mounter
PR: 277765
-rw-r--r--deskutils/kdeconnect-kde/Makefile2
-rw-r--r--deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp10
2 files changed, 6 insertions, 6 deletions
diff --git a/deskutils/kdeconnect-kde/Makefile b/deskutils/kdeconnect-kde/Makefile
index b1a517866a50..8f25b2303832 100644
--- a/deskutils/kdeconnect-kde/Makefile
+++ b/deskutils/kdeconnect-kde/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kdeconnect-kde
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp b/deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp
index 99fa7009b2dc..60f8103d702b 100644
--- a/deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp
+++ b/deskutils/kdeconnect-kde/files/patch-plugins_sftp_mounter.cpp
@@ -1,15 +1,15 @@
---- plugins/sftp/mounter.cpp.orig 2022-11-30 00:45:32 UTC
+--- plugins/sftp/mounter.cpp.orig 2024-02-10 04:18:49 UTC
+++ plugins/sftp/mounter.cpp
-@@ -129,7 +129,7 @@ void Mounter::onPackageReceived(const NetworkPacket &n
- << QStringLiteral("-o") << QStringLiteral("HostKeyAlgorithms=+ssh-dss\\,ssh-rsa") // https://bugs.kde.org/show_bug.cgi?id=351725
+@@ -130,7 +130,7 @@ void Mounter::onPackageReceived(const NetworkPacket &n
+ << QStringLiteral("-o") << QStringLiteral("PubkeyAcceptedKeyTypes=+ssh-rsa") // https://bugs.kde.org/show_bug.cgi?id=443155
<< QStringLiteral("-o") << QStringLiteral("uid=") + QString::number(getuid()) << QStringLiteral("-o")
<< QStringLiteral("gid=") + QString::number(getgid()) << QStringLiteral("-o") << QStringLiteral("reconnect") << QStringLiteral("-o")
- << QStringLiteral("ServerAliveInterval=30") << QStringLiteral("-o") << QStringLiteral("password_stdin");
-+ << QStringLiteral("-o") << QStringLiteral("ssh_command=sshpass -p %1 %2").arg(np.get<QString>(QStringLiteral("password")), QStringLiteral("ssh"));
++ << QStringLiteral("ServerAliveInterval=30") << QStringLiteral("-o") << QStringLiteral("ssh_command=sshpass -p %1 %2").arg(np.get<QString>(QStringLiteral("password")), QStringLiteral("ssh"));
m_proc->setProgram(program, arguments);
-@@ -137,8 +137,8 @@ void Mounter::onPackageReceived(const NetworkPacket &n
+@@ -138,8 +138,8 @@ void Mounter::onPackageReceived(const NetworkPacket &n
m_proc->start();
// qCDebug(KDECONNECT_PLUGIN_SFTP) << "Passing password: " << np.get<QString>("password").toLatin1();