aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvgeniy Khramtsov <evgeniy@khramtsov.org>2021-06-10 06:46:30 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2021-06-10 06:46:30 +0000
commit689dca24f212dc55297c5d1bb7132b0c175bcfc2 (patch)
tree924441c3dfed18e60ab9a8bbcb282aadd3bc4028
parentfb887fe458fa9185dd46dbe80c3c5fc707afc709 (diff)
downloadports-689dca24f212dc55297c5d1bb7132b0c175bcfc2.tar.gz
ports-689dca24f212dc55297c5d1bb7132b0c175bcfc2.zip
graphics/imv: allow building on Wayland-only
imv can work on a system where libX11 is fully removed and OpenGL is provided by libOpenGL instead of libGL[1]. USE_GL=gl implies lib-depends on libGL, which is built only when X11 symbols are available, which is not always the case. libglvnd provides libOpenGL which provides OpenGL symbols without X11 symbols. To satisfy poudriere testport, do USE_GL=egl because there is no libOpenGL handling in Mk/Uses/gl.mk currently. libEGL is supposed to always exist per pkg-plist of mesa-*. Adjust USE_GL for imv to build on global X11=off XCB=off XLIB=off. [1]: https://github.com/eXeC64/imv/commit/ 70a70727b74c532ffb303023b3eb215310948b31 Rebased version is always available here: https://codeberg.org/ei/ports/commits/branch/ei PR: 256419 Approved by: dbaio, garga (mentors) Differential Revision: https://reviews.freebsd.org/D30694
-rw-r--r--graphics/imv/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/graphics/imv/Makefile b/graphics/imv/Makefile
index 8efed9f1736b..2115ee82e280 100644
--- a/graphics/imv/Makefile
+++ b/graphics/imv/Makefile
@@ -1,6 +1,7 @@
PORTNAME= imv
DISTVERSIONPREFIX= v
DISTVERSION= 4.2.0
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= eduardo@FreeBSD.org
@@ -18,7 +19,7 @@ USES= compiler:c11 desktop-file-utils gettext-runtime gl gnome \
meson pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= eXeC64
-USE_GL= gl
+USE_GL= egl
USE_GNOME= cairo glib20 pango
PLIST_FILES= bin/imv \
@@ -42,7 +43,7 @@ WIN_DESC= Windowing system
ALL_LIB_DEPENDS+= libwayland-client.so:graphics/wayland
ALL_USES= xorg
-ALL_USE= gl=egl,glu xorg=x11,xcb
+ALL_USE= gl=glu xorg=x11,xcb
ALL_MESON_ON= -Dwindows=all
ALL_PLIST_FILES= bin/imv-wayland \
bin/imv-x11
@@ -73,8 +74,6 @@ TIFF_MESON_ENABLED= libtiff
WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland \
libwayland-egl.so:graphics/wayland
-
-WAYLAND_USE= gl=egl
WAYLAND_MESON_ON= -Dwindows=wayland
X11_USES= xorg