aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2024-06-14 17:40:18 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-06-15 09:12:24 +0000
commit68be1b1411cee3fcb34658b65914aedcc64dc873 (patch)
tree7ad0f0b5fa149c2f650a3812b954815b8ac128c8
parent4c6970a7b82561887ab6e6190fd81089ec4009aa (diff)
downloadports-68be1b1411cee3fcb34658b65914aedcc64dc873.tar.gz
ports-68be1b1411cee3fcb34658b65914aedcc64dc873.zip
science/hypre: don’t use internal BLAS but switch to OpenBLAS
USES is set to blaslapack, but the internal BLAS and LAPACK libraries are used: switch to the external OpenBLAS. Since I’m there, also build with SUPERLU. PR: 279739 Approved by: yuri (maintainer)
-rw-r--r--science/hypre/Makefile11
-rw-r--r--science/hypre/pkg-plist4
2 files changed, 9 insertions, 6 deletions
diff --git a/science/hypre/Makefile b/science/hypre/Makefile
index b74295970e5e..a740fd533fc5 100644
--- a/science/hypre/Makefile
+++ b/science/hypre/Makefile
@@ -1,6 +1,7 @@
PORTNAME= hypre
DISTVERSIONPREFIX= v
DISTVERSION= 2.31.0
+PORTREVISION= 1
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -12,7 +13,9 @@ LICENSE_COMB= dual
LICENSE_FILE_APACHE20= ${WRKSRC}/../LICENSE-APACHE
LICENSE_FILE_MIT= ${WRKSRC}/../LICENSE-MIT
-USES= blaslapack cmake:testing fortran localbase
+LIB_DEPENDS= libsuperlu.so:math/superlu
+
+USES= blaslapack:openblas cmake:testing fortran localbase
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -20,7 +23,11 @@ GH_ACCOUNT= hypre-space
WRKSRC_SUBDIR= src
-CMAKE_ON= HYPRE_ENABLE_SHARED HYPRE_WITH_OPENMP
+CMAKE_ON= HYPRE_ENABLE_SHARED HYPRE_WITH_OPENMP HYPRE_WITH_SUPERLU
+CMAKE_OFF= HYPRE_ENABLE_HYPRE_BLAS HYPRE_ENABLE_HYPRE_LAPACK
+CMAKE_ARGS= -DTPL_BLAS_LIBRARIES="${_BLASLIB}" \
+ -DTPL_SUPERLU_LIBRARIES="${LOCALBASE}/lib/libsuperlu.so" \
+ -DTPL_SUPERLU_INCLUDE_DIRS="${LOCALBASE}/include/superlu"
CMAKE_TESTING_ON= HYPRE_BUILD_TESTS # tests are only built and not run, see https://github.com/hypre-space/hypre/issues/502
OPTIONS_DEFINE= DOCS
diff --git a/science/hypre/pkg-plist b/science/hypre/pkg-plist
index 232b6f092f39..d505f57cbf50 100644
--- a/science/hypre/pkg-plist
+++ b/science/hypre/pkg-plist
@@ -23,8 +23,6 @@ include/HYPREf.h
include/IJ_matrix.h
include/IJ_vector.h
include/_hypre_IJ_mv.h
-include/_hypre_blas.h
-include/_hypre_lapack.h
include/_hypre_parcsr_ls.h
include/_hypre_parcsr_mv.h
include/_hypre_seq_block_mv.h
@@ -39,10 +37,8 @@ include/aux_parcsr_matrix.h
include/csr_block_matrix.h
include/csr_matmultivec.h
include/distributed_matrix.h
-include/f2c.h
include/fortran.h
include/fortran_matrix.h
-include/hypre_blas.h
include/interpreter.h
include/krylov.h
include/lobpcg.h