aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-05-23 02:40:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-05-23 03:04:46 +0000
commit6935d41767359f8556328e454b905781035fac84 (patch)
treef6cb21fb346e2c9ae6ef601e7bf98ef273271bbf
parent8753f725fd741506707b31385f4373a773da299a (diff)
downloadports-6935d41767359f8556328e454b905781035fac84.tar.gz
ports-6935d41767359f8556328e454b905781035fac84.zip
net/zmap: Remove dropped options, move dependency from option to LIB_DEPENDS
-rw-r--r--net/zmap/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/net/zmap/Makefile b/net/zmap/Makefile
index ad084e1aea06..7599495c1983 100644
--- a/net/zmap/Makefile
+++ b/net/zmap/Makefile
@@ -1,6 +1,7 @@
PORTNAME= zmap
DISTVERSIONPREFIX= v
DISTVERSION= 4.1.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/judy/judy/Judy-1.0.5/:judy
DISTFILES= Judy-1.0.5.tar.gz:judy
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= gengetopt>0:devel/gengetopt \
gmake:devel/gmake
-LIB_DEPENDS= libdnet.so:net/libdnet \
+LIB_DEPENDS= libjson-c.so:devel/json-c \
libgmp.so:math/gmp \
libunistring.so:devel/libunistring
@@ -31,19 +32,6 @@ CMAKE_ON= FORCE_CONF_INSTALL
MANPAGE= zblacklist.1 zmap.1 ztee.1
-OPTIONS_DEFINE= REDIS MONGO JSON
-OPTIONS_DEFAULT=JSON
-JSON_DESC= Build with support for JSON
-
-REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
-REDIS_CMAKE_BOOL= WITH_REDIS
-
-MONGO_LIB_DEPENDS= libmongoc-1.0.so:devel/mongo-c-driver
-MONGO_CMAKE_BOOL= WITH_MONGO
-
-JSON_LIB_DEPENDS= libjson-c.so:devel/json-c
-JSON_CMAKE_BOOL= WITH_JSON
-
pre-build: # build the Judy library
@cd ${JUDY_WRKSRC} && \
${SETENV} ${MAKE_ENV} ./configure --disable-shared && \