aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2024-05-23 12:00:01 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2024-05-23 12:07:42 +0000
commit694ab437cf2940378c9a9d2fe9281c87441d5ac0 (patch)
tree727b36bcf94ca06ea76e808de8e6ca463eb0fb29
parente10c49f8cfc9740ffdba30c6d3b0c909268b991a (diff)
downloadports-694ab437cf2940378c9a9d2fe9281c87441d5ac0.tar.gz
ports-694ab437cf2940378c9a9d2fe9281c87441d5ac0.zip
databases/xtrabackup80: unbreak build with clang18
Reported by: Eugene M. Zheganin (maintainer) Approved by: Eugene M. Zheganin (maintainer)
-rw-r--r--databases/xtrabackup80/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/databases/xtrabackup80/Makefile b/databases/xtrabackup80/Makefile
index 7004a9812a23..47be5e87e030 100644
--- a/databases/xtrabackup80/Makefile
+++ b/databases/xtrabackup80/Makefile
@@ -80,6 +80,10 @@ LIB_DEPENDS+= libcurl.so:ftp/curl \
libunwind.so:devel/libunwind \
libzstd.so:archivers/zstd
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 180
+CXXFLAGS+= -Wno-enum-constexpr-conversion
+.endif
+
.for component in EDITLINE ICU LIBEVENT PROTOBUF RAPIDJSON ZSTD
CMAKE_ARGS+= -DWITH_${component}:STRING=system
.endfor