aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-01-31 05:24:05 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-01-31 05:33:40 +0000
commit69beefcd6c22c38ec003efafe329d59481d02d70 (patch)
treec90348743f1a7fd9140044deffc596c96c34d07b
parentd197a1aed78206ac49002b63ede04bbeec79fb45 (diff)
downloadports-69beefcd6c22c38ec003efafe329d59481d02d70.tar.gz
ports-69beefcd6c22c38ec003efafe329d59481d02d70.zip
x11-wm/wlmaker: unbreak build on non-x86 architectures
Upstream defines _POSIX_C_SOURCE to 1, 199309L, 200112L, 200809L in multiple files, all of which hide SIGTRAP on FreeBSD. Drop POSIX as BSD (unlike GNU) enable extensions by default. submodules/libbase/subprocess.c:496:9: error: use of undeclared identifier 'SIGTRAP' 496 | BS_ASSERT(rv == subprocess_ptr->pid); | ^ submodules/libbase/assert.h:45:13: note: expanded from macro 'BS_ASSERT' 45 | BS_ABORT(); \ | ^ submodules/libbase/assert.h:34:28: note: expanded from macro 'BS_ABORT' 34 | #define BS_ABORT() { raise(SIGTRAP); } | ^ PR: 276743 Reported by: pkg-fallout (aarch64)
-rw-r--r--x11-wm/wlmaker/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/x11-wm/wlmaker/Makefile b/x11-wm/wlmaker/Makefile
index 97d4b47a1603..f7bcf8d18d99 100644
--- a/x11-wm/wlmaker/Makefile
+++ b/x11-wm/wlmaker/Makefile
@@ -43,5 +43,8 @@ post-patch:
-e 's/google-chrome/chrome/' \
${WRKSRC}/src/dock.c \
${WRKSRC}/src/${PORTNAME}.c
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=276743
+ @${GREP} -Flr _POSIX_C_SOURCE ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
+ '/_POSIX_C_SOURCE/d'
.include <bsd.port.mk>