aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-18 21:41:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-18 22:50:45 +0000
commit6a4356a0f431c643b10e1c085eb7fb77ce7fd732 (patch)
tree2fa09c732d5a17125448e3ccc32ecd62d3689cd5
parentc71f5b34dc5ac3b38acf9256b560ad3dfb46a3fb (diff)
downloadports-6a4356a0f431c643b10e1c085eb7fb77ce7fd732.tar.gz
ports-6a4356a0f431c643b10e1c085eb7fb77ce7fd732.zip
devel/nlohmann-json: Update 3.9.1 -> 3.10.0
Reported by: portscout
-rw-r--r--devel/bear/Makefile2
-rw-r--r--devel/nlohmann-json/Makefile5
-rw-r--r--devel/nlohmann-json/distinfo6
-rw-r--r--devel/nlohmann-json/pkg-plist2
4 files changed, 9 insertions, 6 deletions
diff --git a/devel/bear/Makefile b/devel/bear/Makefile
index f55574ded586..15addf396373 100644
--- a/devel/bear/Makefile
+++ b/devel/bear/Makefile
@@ -10,6 +10,8 @@ COMMENT= Tool that generates a compilation database for clang tooling
LICENSE= GPLv3+
+BROKEN= Incompatible with nlohmann-json-3.10.0, see https://github.com/rizsotto/Bear/issues/396
+
BUILD_DEPENDS= nlohmann-json>0:devel/nlohmann-json
LIB_DEPENDS= libabsl_hash.so:devel/abseil \
libcares.so:dns/c-ares \
diff --git a/devel/nlohmann-json/Makefile b/devel/nlohmann-json/Makefile
index 41b6ffcbce8c..a6e92b6c1a1f 100644
--- a/devel/nlohmann-json/Makefile
+++ b/devel/nlohmann-json/Makefile
@@ -2,8 +2,7 @@
PORTNAME= json
DISTVERSIONPREFIX= v
-DISTVERSION= 3.9.1
-PORTREVISION= 2
+DISTVERSION= 3.10.0
CATEGORIES= devel
PKGNAMEPREFIX= nlohmann-
@@ -23,7 +22,7 @@ NO_ARCH= yes
CMAKE_ON= JSON_MultipleHeaders
CMAKE_OFF= JSON_BuildTests
-do-test:
+do-test: # 2 tests are expected to fail, see https://github.com/nlohmann/json/issues/2951
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DJSON_BuildTests:BOOL=ON ${CMAKE_SOURCE_PATH} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
diff --git a/devel/nlohmann-json/distinfo b/devel/nlohmann-json/distinfo
index 5ef098df5d39..5d4b2d6adae9 100644
--- a/devel/nlohmann-json/distinfo
+++ b/devel/nlohmann-json/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1596777581
-SHA256 (nlohmann-json-v3.9.1_GH0.tar.gz) = 4cf0df69731494668bdd6460ed8cb269b68de9c19ad8c27abc24cd72605b2d5b
-SIZE (nlohmann-json-v3.9.1_GH0.tar.gz) = 6882818
+TIMESTAMP = 1629304548
+SHA256 (nlohmann-json-v3.10.0_GH0.tar.gz) = eb8b07806efa5f95b349766ccc7a8ec2348f3b2ee9975ad879259a371aea8084
+SIZE (nlohmann-json-v3.10.0_GH0.tar.gz) = 7006504
diff --git a/devel/nlohmann-json/pkg-plist b/devel/nlohmann-json/pkg-plist
index 26cc1277304f..ab779029d441 100644
--- a/devel/nlohmann-json/pkg-plist
+++ b/devel/nlohmann-json/pkg-plist
@@ -23,12 +23,14 @@ include/nlohmann/detail/macro_scope.hpp
include/nlohmann/detail/macro_unscope.hpp
include/nlohmann/detail/meta/cpp_future.hpp
include/nlohmann/detail/meta/detected.hpp
+include/nlohmann/detail/meta/identity_tag.hpp
include/nlohmann/detail/meta/is_sax.hpp
include/nlohmann/detail/meta/type_traits.hpp
include/nlohmann/detail/meta/void_t.hpp
include/nlohmann/detail/output/binary_writer.hpp
include/nlohmann/detail/output/output_adapters.hpp
include/nlohmann/detail/output/serializer.hpp
+include/nlohmann/detail/string_escape.hpp
include/nlohmann/detail/value_t.hpp
include/nlohmann/json.hpp
include/nlohmann/json_fwd.hpp