aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-07 18:47:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-07 18:48:04 +0000
commit6ac6ffa00fac8f68c205532c80160fb3a2083f42 (patch)
tree65415becc4b36cc8b83f48e8540f96db5b4c62ae
parent09c0c446eec07833dab83f04d4575687e375edc8 (diff)
downloadports-6ac6ffa00fac8f68c205532c80160fb3a2083f42.tar.gz
ports-6ac6ffa00fac8f68c205532c80160fb3a2083f42.zip
math/universal: Update 3.0.0 -> 3.32.1
Reported by: portscout
-rw-r--r--math/universal/Makefile12
-rw-r--r--math/universal/distinfo6
-rw-r--r--math/universal/pkg-plist135
3 files changed, 123 insertions, 30 deletions
diff --git a/math/universal/Makefile b/math/universal/Makefile
index 359d0ddc4ebd..f781898cb310 100644
--- a/math/universal/Makefile
+++ b/math/universal/Makefile
@@ -1,5 +1,6 @@
PORTNAME= universal
-DISTVERSION= 3.0.0
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.32.1
CATEGORIES= math
PKGNAMESUFFIX= -fp-library
@@ -9,21 +10,20 @@ COMMENT= Header-only C++ template library for universal number arithmetic
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake
+USES= cmake compiler:c++17-lang # should be compiler:c++20-lang
USE_GITHUB= yes
GH_ACCOUNT= stillwater-sc
-CMAKE_OFF= UNIVERSAL_ENABLE_TESTS BUILD_PLAYGROUND BUILD_EDUCATION BUILD_APPLICATIONS
+CMAKE_OFF= UNIVERSAL_ENABLE_TESTS BUILD_DEMONSTRATION BUILD_PLAYGROUND BUILD_EDUCATION BUILD_APPLICATIONS
OPTIONS_DEFINE= TOOLS
OPTIONS_SUB= yes
TOOLS_DESC= Build command line tools
TOOLS_CMAKE_BOOL= BUILD_CMD_LINE_TOOLS
-TOOLS_USES= compiler:c++14-lang
-TOOLS_VARS_OFF= NO_ARCH=yes
+TOOLS_VARS_OFF= NO_ARCH=yes # header-only library w/out executables
-do-test: # 2 tests are known to fail: https://github.com/stillwater-sc/universal/issues/154
+do-test:
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${CMAKE_OFF:C/(.*)/-D\1=ON/} ${CMAKE_SOURCE_PATH} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
diff --git a/math/universal/distinfo b/math/universal/distinfo
index a0ad6e0c8435..9b0cdaeabd04 100644
--- a/math/universal/distinfo
+++ b/math/universal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613171959
-SHA256 (stillwater-sc-universal-3.0.0_GH0.tar.gz) = 938c11d18a4fe48645b85b590f297710dc6ba28cffa70cb324225fba4f1e4675
-SIZE (stillwater-sc-universal-3.0.0_GH0.tar.gz) = 108005247
+TIMESTAMP = 1628359214
+SHA256 (stillwater-sc-universal-v3.32.1_GH0.tar.gz) = ee4ab15df438ba7370fea35c3c79cd53a242407573b503372a8b2373428db94b
+SIZE (stillwater-sc-universal-v3.32.1_GH0.tar.gz) = 110968772
diff --git a/math/universal/pkg-plist b/math/universal/pkg-plist
index a0e3c6a2d5ce..f7a2513f9f46 100644
--- a/math/universal/pkg-plist
+++ b/math/universal/pkg-plist
@@ -1,20 +1,20 @@
-%%TOOLS%%bin/compd
-%%TOOLS%%bin/compf
-%%TOOLS%%bin/compfp
-%%TOOLS%%bin/compieee
-%%TOOLS%%bin/compld
-%%TOOLS%%bin/complns
-%%TOOLS%%bin/compp
-%%TOOLS%%bin/compsi
-%%TOOLS%%bin/compui
+%%TOOLS%%bin/areal
+%%TOOLS%%bin/double
+%%TOOLS%%bin/fixpnt
+%%TOOLS%%bin/float
%%TOOLS%%bin/float2posit
+%%TOOLS%%bin/ieee
+%%TOOLS%%bin/lns
+%%TOOLS%%bin/longdouble
%%TOOLS%%bin/plimits
+%%TOOLS%%bin/posit
%%TOOLS%%bin/propenv
%%TOOLS%%bin/propp
%%TOOLS%%bin/propq
+%%TOOLS%%bin/signedint
+%%TOOLS%%bin/unsignedint
include/universal/README.md
include/universal/adapters/adapt_integer_and_posit.hpp
-include/universal/blas/blas
include/universal/blas/blas.hpp
include/universal/blas/blas_l1.hpp
include/universal/blas/blas_l2.hpp
@@ -23,10 +23,13 @@ include/universal/blas/exceptions.hpp
include/universal/blas/generators.hpp
include/universal/blas/generators/frank.hpp
include/universal/blas/generators/fvm64x64.hpp
+include/universal/blas/generators/gaussian_random.hpp
include/universal/blas/generators/hilbert.hpp
include/universal/blas/generators/index.hpp
include/universal/blas/generators/laplace2D.hpp
include/universal/blas/generators/magic.hpp
+include/universal/blas/generators/minij.hpp
+include/universal/blas/generators/randsvd.hpp
include/universal/blas/generators/tridiag.hpp
include/universal/blas/generators/uniform_random.hpp
include/universal/blas/inverse.hpp
@@ -39,11 +42,14 @@ include/universal/blas/solvers/cg_dot_dot.hpp
include/universal/blas/solvers/cg_dot_fdp.hpp
include/universal/blas/solvers/cg_fdp_dot.hpp
include/universal/blas/solvers/cg_fdp_fdp.hpp
+include/universal/blas/solvers/find_rank.hpp
include/universal/blas/solvers/gauss_seidel.hpp
include/universal/blas/solvers/jacobi.hpp
include/universal/blas/solvers/lsq.hpp
include/universal/blas/solvers/lu.hpp
+include/universal/blas/solvers/qr.hpp
include/universal/blas/solvers/sor.hpp
+include/universal/blas/solvers/svd.hpp
include/universal/blas/vector.hpp
include/universal/blas/vmath/power.hpp
include/universal/blas/vmath/trigonometry.hpp
@@ -56,6 +62,7 @@ include/universal/functions/isrepresentable.hpp
include/universal/functions/lerp.hpp
include/universal/functions/loss.hpp
include/universal/functions/twosum.hpp
+include/universal/hw/alu.hpp
include/universal/internal/abstract/triple.hpp
include/universal/internal/bitblock/README.md
include/universal/internal/bitblock/bitblock.hpp
@@ -63,37 +70,107 @@ include/universal/internal/bitblock/bitblock_v2.hpp
include/universal/internal/bitblock/exceptions.hpp
include/universal/internal/bitblock/ubb.h
include/universal/internal/blockbinary/blockbinary.hpp
+include/universal/internal/blockfraction/blockfraction.hpp
include/universal/internal/blocktriple/blocktriple.hpp
include/universal/internal/blocktriple/trace_constants.hpp
include/universal/internal/value/value
include/universal/internal/value/value.hpp
+include/universal/math/README.md
+include/universal/math/TODO
+include/universal/math/complex_manipulators.hpp
+include/universal/math/math
+include/universal/math/math_constants.hpp
+include/universal/math/math_functions.hpp
+include/universal/math/stub/abs.hpp
+include/universal/math/stub/classify.hpp
+include/universal/math/stub/complex.hpp
+include/universal/math/stub/error_and_gamma.hpp
+include/universal/math/stub/exponent.hpp
+include/universal/math/stub/fractional.hpp
+include/universal/math/stub/hyperbolic.hpp
+include/universal/math/stub/hypot.hpp
+include/universal/math/stub/logarithm.hpp
+include/universal/math/stub/minmax.hpp
+include/universal/math/stub/next.hpp
+include/universal/math/stub/pow.hpp
+include/universal/math/stub/sqrt.hpp
+include/universal/math/stub/trigonometry.hpp
+include/universal/math/stub/truncate.hpp
include/universal/native/bit_functions.hpp
include/universal/native/boolean_logic_operators.hpp
+include/universal/native/constexpr754.hpp
include/universal/native/ieee754.hpp
+include/universal/native/ieee754_clang.hpp
+include/universal/native/ieee754_gcc.hpp
+include/universal/native/ieee754_hpcc.hpp
+include/universal/native/ieee754_ibmxlc.hpp
+include/universal/native/ieee754_intelicc.hpp
+include/universal/native/ieee754_msvc.hpp
+include/universal/native/ieee754_pgi.hpp
+include/universal/native/ieee754_riscv.hpp
+include/universal/native/ieee754_sunpro.hpp
include/universal/native/integers.hpp
include/universal/native/manipulators.hpp
-include/universal/native/native
+include/universal/native/native.hpp
+include/universal/native/nonconstexpr/clang_long_double.hpp
+include/universal/native/nonconstexpr/gcc_long_double.hpp
+include/universal/native/nonconstexpr/hpcc_long_double.hpp
+include/universal/native/nonconstexpr/ibmxlc_long_double.hpp
+include/universal/native/nonconstexpr/intelicc_long_double.hpp
+include/universal/native/nonconstexpr/msvc_long_double.hpp
+include/universal/native/nonconstexpr/pgi_long_double.hpp
+include/universal/native/nonconstexpr/riscv_long_double.hpp
+include/universal/native/nonconstexpr/sunpro_long_double.hpp
+include/universal/native/nonconstexpr/use
+include/universal/native/nonconstexpr754.hpp
+include/universal/native/subnormal.hpp
include/universal/number/adaptivefloat/adaptivefloat.hpp
+include/universal/number/adaptivefloat/adaptivefloat_impl.hpp
include/universal/number/adaptivefloat/exceptions.hpp
include/universal/number/adaptiveint/adaptiveint.hpp
+include/universal/number/adaptiveint/adaptiveint_impl.hpp
include/universal/number/adaptiveint/exceptions.hpp
include/universal/number/adaptiveposit/adaptiveposit.hpp
+include/universal/number/adaptiveposit/adaptiveposit_impl.hpp
include/universal/number/adaptiveposit/exceptions.hpp
-include/universal/number/areal/areal
include/universal/number/areal/areal.hpp
+include/universal/number/areal/areal_impl.hpp
include/universal/number/areal/exceptions.hpp
include/universal/number/areal/manipulators.hpp
include/universal/number/areal/math_functions.hpp
include/universal/number/areal/numeric_limits.hpp
include/universal/number/areal/table.hpp
-include/universal/number/decimal/decimal
+include/universal/number/cfloat/cfloat.hpp
+include/universal/number/cfloat/cfloat_fwd.hpp
+include/universal/number/cfloat/cfloat_impl.hpp
+include/universal/number/cfloat/exceptions.hpp
+include/universal/number/cfloat/manipulators.hpp
+include/universal/number/cfloat/math/classify.hpp
+include/universal/number/cfloat/math/complex.hpp
+include/universal/number/cfloat/math/error_and_gamma.hpp
+include/universal/number/cfloat/math/exponent.hpp
+include/universal/number/cfloat/math/fractional.hpp
+include/universal/number/cfloat/math/hyperbolic.hpp
+include/universal/number/cfloat/math/hypot.hpp
+include/universal/number/cfloat/math/logarithm.hpp
+include/universal/number/cfloat/math/minmax.hpp
+include/universal/number/cfloat/math/next.hpp
+include/universal/number/cfloat/math/pow.hpp
+include/universal/number/cfloat/math/sqrt.hpp
+include/universal/number/cfloat/math/sqrt_tables.hpp
+include/universal/number/cfloat/math/trigonometry.hpp
+include/universal/number/cfloat/math/truncate.hpp
+include/universal/number/cfloat/math_functions.hpp
+include/universal/number/cfloat/numeric_limits.hpp
+include/universal/number/cfloat/table.hpp
include/universal/number/decimal/decimal.hpp
+include/universal/number/decimal/decimal_impl.hpp
include/universal/number/decimal/exceptions.hpp
include/universal/number/decimal/numeric_limits.hpp
include/universal/number/fixpnt/attributes.hpp
include/universal/number/fixpnt/exceptions.hpp
-include/universal/number/fixpnt/fixpnt
include/universal/number/fixpnt/fixpnt.hpp
+include/universal/number/fixpnt/fixpnt_impl.hpp
include/universal/number/fixpnt/manipulators.hpp
include/universal/number/fixpnt/math_functions.hpp
include/universal/number/fixpnt/numeric_limits.hpp
@@ -102,16 +179,16 @@ include/universal/number/float/float_functions.hpp
include/universal/number/float/quire.hpp
include/universal/number/integer/attributes.hpp
include/universal/number/integer/exceptions.hpp
-include/universal/number/integer/integer
include/universal/number/integer/integer.hpp
+include/universal/number/integer/integer_impl.hpp
include/universal/number/integer/manipulators.hpp
include/universal/number/integer/math_functions.hpp
include/universal/number/integer/numeric_limits.hpp
include/universal/number/integer/primes.hpp
include/universal/number/integer/sieves.hpp
include/universal/number/lns/exceptions.hpp
-include/universal/number/lns/lns
include/universal/number/lns/lns.hpp
+include/universal/number/lns/lns_impl.hpp
include/universal/number/lns/math_functions.hpp
include/universal/number/lns/numeric_limits.hpp
include/universal/number/posit/ReadMe.txt
@@ -123,7 +200,6 @@ include/universal/number/posit/fraction.hpp
include/universal/number/posit/manipulators.hpp
include/universal/number/posit/math/classify.hpp
include/universal/number/posit/math/complex.hpp
-include/universal/number/posit/math/constants.hpp
include/universal/number/posit/math/error_and_gamma.hpp
include/universal/number/posit/math/exponent.hpp
include/universal/number/posit/math/fractional.hpp
@@ -139,11 +215,11 @@ include/universal/number/posit/math/trigonometry.hpp
include/universal/number/posit/math/truncate.hpp
include/universal/number/posit/math_functions.hpp
include/universal/number/posit/numeric_limits.hpp
-include/universal/number/posit/posit
include/universal/number/posit/posit.hpp
include/universal/number/posit/posit_c_api.h
include/universal/number/posit/posit_c_macros.h
include/universal/number/posit/posit_fwd.hpp
+include/universal/number/posit/posit_impl.hpp
include/universal/number/posit/posit_parse.hpp
include/universal/number/posit/positctypes.h
include/universal/number/posit/quire.hpp
@@ -156,6 +232,7 @@ include/universal/number/posit/specialized/posit_2_0.hpp
include/universal/number/posit/specialized/posit_32_2.hpp
include/universal/number/posit/specialized/posit_3_0.hpp
include/universal/number/posit/specialized/posit_3_1.hpp
+include/universal/number/posit/specialized/posit_48_2.hpp
include/universal/number/posit/specialized/posit_4_0.hpp
include/universal/number/posit/specialized/posit_64_3.hpp
include/universal/number/posit/specialized/posit_8_0.h
@@ -166,6 +243,9 @@ include/universal/number/posit/table.hpp
include/universal/number/posit/trace_constants.hpp
include/universal/number/posit/twoSum.hpp
include/universal/number/quire/exceptions.hpp
+include/universal/number/shared/infinite_encoding.hpp
+include/universal/number/shared/nan_encoding.hpp
+include/universal/number/shared/specific_value_encoding.hpp
include/universal/number/skeleton_1param/exceptions.hpp
include/universal/number/skeleton_1param/lns
include/universal/number/skeleton_1param/lns.hpp
@@ -180,17 +260,17 @@ include/universal/number/unum/exceptions.hpp
include/universal/number/unum/manipulators.hpp
include/universal/number/unum/math_functions.hpp
include/universal/number/unum/numeric_limits.hpp
-include/universal/number/unum/unum
include/universal/number/unum/unum.hpp
+include/universal/number/unum/unum_impl.hpp
include/universal/number/unum2/CMakeLists.txt
include/universal/number/unum2/manipulators.hpp
include/universal/number/unum2/math_functions.hpp
-include/universal/number/unum2/unum2.hpp
+include/universal/number/unum2/unum2_impl.hpp
include/universal/number/valid/attributes.hpp
include/universal/number/valid/manipulators.hpp
include/universal/number/valid/math_functions.hpp
-include/universal/number/valid/valid
include/universal/number/valid/valid.hpp
+include/universal/number/valid/valid_impl.hpp
include/universal/performance/number_system.hpp
include/universal/sequences/fibonacci.hpp
include/universal/sequences/tribonacci.hpp
@@ -201,16 +281,25 @@ include/universal/traits/integral_constant.hpp
include/universal/traits/metaprogramming.hpp
include/universal/traits/number_traits.hpp
include/universal/traits/posit_traits.hpp
+include/universal/utility/bit_cast.hpp
+include/universal/utility/bitcast.hpp
include/universal/utility/color_print.hpp
include/universal/utility/compiler_specialization.hpp
+include/universal/utility/convert_to.hpp
+include/universal/utility/directives.hpp
include/universal/utility/error.hpp
include/universal/utility/number_system_properties.hpp
+include/universal/utility/occurrence.hpp
include/universal/utility/reverse_view.hpp
+include/universal/utility/scientific.hpp
include/universal/verification/README.md
include/universal/verification/areal_test_suite.hpp
include/universal/verification/binaryop_status.hpp
include/universal/verification/bitblock_test_suite.hpp
include/universal/verification/blockbinary_test_status.hpp
+include/universal/verification/blocktriple_test_status.hpp
+include/universal/verification/cfloat_math_test_suite.hpp
+include/universal/verification/cfloat_test_suite.hpp
include/universal/verification/fixpnt_test_suite.hpp
include/universal/verification/integer_test_suite.hpp
include/universal/verification/performance_runner.hpp
@@ -221,7 +310,11 @@ include/universal/verification/quire_test_suite.hpp
include/universal/verification/skeleton_test_suite.hpp
include/universal/verification/test_reporters.hpp
include/universal/verification/test_status.hpp
+include/universal/verification/test_suite.hpp
include/universal/verification/test_suite_arithmetic.hpp
+include/universal/verification/test_suite_conversion.hpp
+include/universal/verification/test_suite_logic.hpp
+include/universal/verification/test_suite_random.hpp
%%DATADIR%%/universal-config-version.cmake
%%DATADIR%%/universal-config.cmake
%%DATADIR%%/universal-targets.cmake