aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 11:02:54 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-06 12:03:04 +0000
commit6b139f669d8f399035e0f653b7afcefe37a6bb53 (patch)
treeecb1f7aa914991abf56d4992ac580c8468b14cfc
parentb2b4dca94a417f60cce7cb2c3c0955fb80139ce9 (diff)
downloadports-6b139f669d8f399035e0f653b7afcefe37a6bb53.tar.gz
ports-6b139f669d8f399035e0f653b7afcefe37a6bb53.zip
emulators/advancemame: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. - while here, mark as abandonware - port has version 1.4 is from 09-08-2015 - upstream version 3.9 is from 08-09-2018
-rw-r--r--emulators/advancemame/Makefile7
-rw-r--r--emulators/advancemame/files/patch-configure13
2 files changed, 20 insertions, 0 deletions
diff --git a/emulators/advancemame/Makefile b/emulators/advancemame/Makefile
index c683364d1463..c40fbd941391 100644
--- a/emulators/advancemame/Makefile
+++ b/emulators/advancemame/Makefile
@@ -38,12 +38,19 @@ OPTIONS_DEFAULT_i386= ASM
ASM_BUILD_DEPENDS= nasm:devel/nasm
ASM_USE= gcc=any
ASM_CONFIGURE_ENABLE= asm
+FREETYPE_USES= pkgconfig
FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
FREETYPE_CONFIGURE_ENABLE= freetype
SLANG_LIB_DEPENDS= libslang.so:devel/libslang2
SLANG_CONFIGURE_ENABLE= slang
SLANG_LDFLAGS= -lncurses
+BINARY_ALIAS= freetype-config=true
+
+DEPRECATED= Heavily outdated and unmaintained
+EXPIRATION_DATE= 2021-10-31
+
+
.include <bsd.port.options.mk>
.if ${ARCH} == powerpc
diff --git a/emulators/advancemame/files/patch-configure b/emulators/advancemame/files/patch-configure
new file mode 100644
index 000000000000..2cc0f8539583
--- /dev/null
+++ b/emulators/advancemame/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2021-08-06 10:56:54 UTC
++++ configure
+@@ -8359,8 +8359,8 @@ done
+ else
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+- FREETYPECFLAGS=`$ac_lib_freetype_config $ac_lib_freetype_args --cflags`
+- FREETYPELIBS=`$ac_lib_freetype_config $ac_lib_freetype_args --libs`
++ FREETYPECFLAGS=`pkg-config freetype2 --cflags`
++ FREETYPELIBS=`pkg-config freetype2 --libs`
+ CFLAGS="$FREETYPECFLAGS $CFLAGS"
+ LIBS="$FREETYPELIBS $LIBS"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for FreeType2" >&5