aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-29 14:55:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-30 01:53:11 +0000
commit6b2f34c72bac40fd1563764ec61ca1324497ed9c (patch)
treee85a38dc3e978e6f233107cbaf931e094c7de69c
parentdf668c5641be0b1b4c7f2fccb98369c31669b8f9 (diff)
downloadports-6b2f34c72bac40fd1563764ec61ca1324497ed9c.tar.gz
ports-6b2f34c72bac40fd1563764ec61ca1324497ed9c.zip
misc/py-pyct: New port: Python package for common tasks for users: copy examples, fetch data
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-pyct/Makefile21
-rw-r--r--misc/py-pyct/distinfo3
-rw-r--r--misc/py-pyct/pkg-descr8
4 files changed, 33 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 330130110555..4654406d5d30 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -410,6 +410,7 @@
SUBDIR += py-progressbar
SUBDIR += py-progressbar2
SUBDIR += py-pyEDFlib
+ SUBDIR += py-pyct
SUBDIR += py-pyfiglet
SUBDIR += py-pykml
SUBDIR += py-pypatent
diff --git a/misc/py-pyct/Makefile b/misc/py-pyct/Makefile
new file mode 100644
index 000000000000..71672101d27d
--- /dev/null
+++ b/misc/py-pyct/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= pyct
+DISTVERSION= 0.4.8
+CATEGORIES= misc
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python package for common tasks for users: copy examples, fetch data
+WWW= https://github.com/pyviz-dev/pyct
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}param>=1.7.0:devel/py-param@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist pytest
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-pyct/distinfo b/misc/py-pyct/distinfo
new file mode 100644
index 000000000000..588091144d82
--- /dev/null
+++ b/misc/py-pyct/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1664490388
+SHA256 (pyct-0.4.8.tar.gz) = 23d7525b5a1567535c093aea4b9c33809415aa5f018dd77f6eb738b1226df6f7
+SIZE (pyct-0.4.8.tar.gz) = 16265
diff --git a/misc/py-pyct/pkg-descr b/misc/py-pyct/pkg-descr
new file mode 100644
index 000000000000..a9ffef33db07
--- /dev/null
+++ b/misc/py-pyct/pkg-descr
@@ -0,0 +1,8 @@
+pyct is a utility package that includes:
+* pyct.cmd: Makes various commands available to other packages. The same
+ commands are available from within python. Can either add new subcommands
+ to an existing argparse based command if the module has an existing command,
+ or create the entire command if the module has no existing command. Currently,
+ there are commands for copying examples and fetching data.
+* pyct.build: Provides various commands to help package building, primarily as a
+ convenience for project maintainers.