aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2022-06-05 20:47:54 +0000
committerCraig Leres <leres@FreeBSD.org>2022-06-05 20:47:54 +0000
commit6bcbed3a624c056ec373410b1eef68c3163886f0 (patch)
tree9f755e1e7cf9b5cec767e93a2d98173486116bf6
parentff2fcc7fe36865e2739388a6e2261b382f70a780 (diff)
downloadports-6bcbed3a624c056ec373410b1eef68c3163886f0.tar.gz
ports-6bcbed3a624c056ec373410b1eef68c3163886f0.zip
security/libu2f-host: Unbreak build with DOCS disabled
libu2f-host does not successfully configure unless gtk-doc is present and enabled: ===> Configuring for libu2f-host-1.1.10_1 /bin/sh: /usr/local/bin/gtkdocize: not found ===> Mk/Uses/autoreconf.mk: Error running gtkdocize *** Error code 1 So: always enable gtk-doc and build DOCS things just don't install them. PR: 264298
-rw-r--r--security/libu2f-host/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/security/libu2f-host/Makefile b/security/libu2f-host/Makefile
index eeb08da77b96..806f2d4e8ac5 100644
--- a/security/libu2f-host/Makefile
+++ b/security/libu2f-host/Makefile
@@ -11,6 +11,7 @@ LICENSE= LGPL21+ GPLv3+
LICENSE_COMB= multi
BUILD_DEPENDS= gengetopt:devel/gengetopt \
+ gtk-doc>0:textproc/gtk-doc \
help2man:misc/help2man
LIB_DEPENDS= libhidapi.so:comms/hidapi \
libjson-c.so:devel/json-c
@@ -19,6 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/etc/devd/u2f.conf:security/u2f-devd
USES= autoreconf pkgconfig gmake libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= -enable-gtk-doc
INSTALL_TARGET= install-strip
USE_GITHUB= yes
@@ -27,7 +29,4 @@ GH_ACCOUNT= Yubico
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
-DOCS_BUILD_DEPENDS= gtk-doc>0:textproc/gtk-doc
-DOCS_CONFIGURE_ENABLE= gtk-doc
-
.include <bsd.port.mk>