aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Hein <jcfyecrayz@liamekaens.com>2023-04-19 16:09:44 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-04-20 13:36:52 +0000
commit6bf7787c8837b93096cc92cb049a8cf1b87898ce (patch)
tree9025f3380a3c9400f8b4745705823afae14fa6e3
parentee7918215f97225aa0d11d6d876c991ef9788607 (diff)
downloadports-6bf7787c8837b93096cc92cb049a8cf1b87898ce.tar.gz
ports-6bf7787c8837b93096cc92cb049a8cf1b87898ce.zip
security/opencryptoki: fix build as non-root
Simple fix to remove the '-g ' option. Just let the @sample() parameters in pkg-plist set the group permissions. Approved by: hrs (maintainer timeout) MFH: 2023Q2 PR: 269524 (cherry picked from commit 6714a2486ac92293aeed04f5cdac6ac546da0497)
-rw-r--r--security/opencryptoki/files/patch-Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/opencryptoki/files/patch-Makefile.am b/security/opencryptoki/files/patch-Makefile.am
index 7f102a37c1f3..4d718d716928 100644
--- a/security/opencryptoki/files/patch-Makefile.am
+++ b/security/opencryptoki/files/patch-Makefile.am
@@ -51,7 +51,7 @@
if ENABLE_P11SAK
test -f $(DESTDIR)$(sysconfdir)/opencryptoki || $(MKDIR_P) $(DESTDIR)$(sysconfdir)/opencryptoki || true
- test -f $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || $(INSTALL) -g pkcs11 -m 0640 $(srcdir)/usr/sbin/p11sak/p11sak_defined_attrs.conf $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf || true
-+ test -f $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf.sample || $(INSTALL) -g @PKCS11GROUP@ -m 0640 $(srcdir)/usr/sbin/p11sak/p11sak_defined_attrs.conf $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf.sample || true
++ test -f $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf.sample || $(INSTALL) -m 0640 $(srcdir)/usr/sbin/p11sak/p11sak_defined_attrs.conf $(DESTDIR)$(sysconfdir)/opencryptoki/p11sak_defined_attrs.conf.sample || true
endif
if ENABLE_ICATOK
cd $(DESTDIR)$(libdir)/opencryptoki/stdll && \