aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeal Nelson <ports@nicandneal.net>2021-10-28 00:27:49 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2021-10-28 07:17:17 +0000
commit6cb28f4ba9922703a7eb06ed9630248da69ef466 (patch)
tree650afa6f1873a655ccc806ebfb57a67432e59e3c
parent1570b78b94840adb22f563883c73b223ad7ec73b (diff)
downloadports-6cb28f4ba9922703a7eb06ed9630248da69ef466.tar.gz
ports-6cb28f4ba9922703a7eb06ed9630248da69ef466.zip
devel/py-clang: Add new port
This is a stand-alone python library binding the libclang functionality. Currently each llvm port installs it's own version, but this is an option (albeit default) and it's installed in a non-standard location. This port removes the dependency on the option and the need to patch software that uses it to use the non-standard location. PR: 258199
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-clang/Makefile15
-rw-r--r--devel/py-clang/distinfo3
-rw-r--r--devel/py-clang/pkg-descr3
4 files changed, 22 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3b1e3a5d8f8d..7071a721ef14 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4322,6 +4322,7 @@
SUBDIR += py-cheetah3
SUBDIR += py-circuits
SUBDIR += py-ciso8601
+ SUBDIR += py-clang
SUBDIR += py-cld
SUBDIR += py-cle
SUBDIR += py-cleo
diff --git a/devel/py-clang/Makefile b/devel/py-clang/Makefile
new file mode 100644
index 000000000000..b70b04dd45f4
--- /dev/null
+++ b/devel/py-clang/Makefile
@@ -0,0 +1,15 @@
+PORTNAME= clang
+DISTVERSION= 11.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@nicandneal.net
+COMMENT= Python bindings for libclang
+
+LICENSE= NCSA
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-clang/distinfo b/devel/py-clang/distinfo
new file mode 100644
index 000000000000..707a9cce5eeb
--- /dev/null
+++ b/devel/py-clang/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630510923
+SHA256 (clang-11.0.tar.gz) = f838e6475b1fe5c91efb97e80ae19420c39483fd5aa7ef10f03ffb51edc6f8c5
+SIZE (clang-11.0.tar.gz) = 30948
diff --git a/devel/py-clang/pkg-descr b/devel/py-clang/pkg-descr
new file mode 100644
index 000000000000..952d8914f049
--- /dev/null
+++ b/devel/py-clang/pkg-descr
@@ -0,0 +1,3 @@
+This is the python bindings subdir of llvm clang repository.
+
+WWW: https://github.com/llvm-mirror/clang/tree/master/bindings/python