aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:08:39 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:08:39 +0000
commit6ccb2f7f0039dcdf03b2d2a6f7ac07966ab60ec4 (patch)
tree0ceab5f5b6a52fa336e89e6c5c79cc3a1a3c0fcf
parent97e6c88222160701ffaba67547282dca961dcf62 (diff)
downloadports-6ccb2f7f0039dcdf03b2d2a6f7ac07966ab60ec4.tar.gz
ports-6ccb2f7f0039dcdf03b2d2a6f7ac07966ab60ec4.zip
security/py-webauthn: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
-rw-r--r--security/py-webauthn/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/py-webauthn/Makefile b/security/py-webauthn/Makefile
index 6f2b9e976711..403abdcc4ff5 100644
--- a/security/py-webauthn/Makefile
+++ b/security/py-webauthn/Makefile
@@ -1,5 +1,6 @@
PORTNAME= webauthn
PORTVERSION= 1.11.1
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,13 +12,15 @@ WWW= https://github.com/duo-labs/py_webauthn
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=1.4.0:devel/py-asn1crypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cbor2>=5.4.2.post1:devel/py-cbor2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic>=1.10.11:devel/py-pydantic@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=23.2.0,1:security/py-openssl@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent cryptography distutils unittest
+USE_PYTHON= autoplist concurrent cryptography pep517 unittest
NO_ARCH= yes