aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 08:36:18 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 09:04:01 +0000
commit6cf0c4cce78cfdfec5080583fe9b5bf04ee2ad1f (patch)
treeceafa612680855e84cff768e268b25808671c2fc
parentf5b4e30c5ea833239a491db0abc0b0977dce9efc (diff)
downloadports-6cf0c4cce78cfdfec5080583fe9b5bf04ee2ad1f.tar.gz
ports-6cf0c4cce78cfdfec5080583fe9b5bf04ee2ad1f.zip
textproc/py-youseedee: Add py-youseedee 0.3.0
youseedee provides an interface to the UCD. This module allows you to query the Unicode Character Database. The main function to be imported is ucd_data.
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-youseedee/Makefile23
-rw-r--r--textproc/py-youseedee/distinfo3
-rw-r--r--textproc/py-youseedee/files/patch-lib-youseedee-__init__.py11
-rw-r--r--textproc/py-youseedee/pkg-descr2
5 files changed, 40 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7ca46552b5cf..726d801ed566 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1586,6 +1586,7 @@
SUBDIR += py-xmldiff
SUBDIR += py-xmlschema
SUBDIR += py-yapf
+ SUBDIR += py-youseedee
SUBDIR += py-zope.i18nmessageid
SUBDIR += py-zope.structuredtext
SUBDIR += py-zope.tal
diff --git a/textproc/py-youseedee/Makefile b/textproc/py-youseedee/Makefile
new file mode 100644
index 000000000000..133586876cfa
--- /dev/null
+++ b/textproc/py-youseedee/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= youseedee
+PORTVERSION= 0.3.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Interface to the Unicode Character Database
+WWW= https://github.com/simoncozens/youseedee
+
+LICENSE= MIT
+
+RUN_DEPENDS= UCD>=0:textproc/UCD
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%UCDDIR%%|${LOCALBASE}/share/unicode/ucd|' ${WRKSRC}/lib/youseedee/__init__.py
+
+.include <bsd.port.mk>
diff --git a/textproc/py-youseedee/distinfo b/textproc/py-youseedee/distinfo
new file mode 100644
index 000000000000..6c447bae8bbe
--- /dev/null
+++ b/textproc/py-youseedee/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1669057517
+SHA256 (youseedee-0.3.0.tar.gz) = 596c1112230bdd154b6d6c962872933e16748ae8efd7cb2389b922cc9aabcab0
+SIZE (youseedee-0.3.0.tar.gz) = 9832
diff --git a/textproc/py-youseedee/files/patch-lib-youseedee-__init__.py b/textproc/py-youseedee/files/patch-lib-youseedee-__init__.py
new file mode 100644
index 000000000000..94141fa40ac7
--- /dev/null
+++ b/textproc/py-youseedee/files/patch-lib-youseedee-__init__.py
@@ -0,0 +1,11 @@
+--- lib/youseedee/__init__.py.orig 2020-10-06 16:13:22 UTC
++++ lib/youseedee/__init__.py
+@@ -9,7 +9,7 @@ import csv
+ UCD_URL = "https://unicode.org/Public/UCD/latest/ucd/UCD.zip"
+
+ def ucd_dir():
+- ucddir = os.path.expanduser("~/.youseedee")
++ ucddir = "%%UCDDIR%%"
+ if not os.path.isdir(ucddir):
+ os.mkdir(ucddir)
+ return ucddir
diff --git a/textproc/py-youseedee/pkg-descr b/textproc/py-youseedee/pkg-descr
new file mode 100644
index 000000000000..c60060d4a9d4
--- /dev/null
+++ b/textproc/py-youseedee/pkg-descr
@@ -0,0 +1,2 @@
+youseedee provides an interface to the UCD. This module allows you to query the
+Unicode Character Database. The main function to be imported is ucd_data.