aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2021-08-02 22:32:55 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2021-08-02 22:35:45 +0000
commit6cfa70cdefcc68a5ff8afb9469c643a91cc25273 (patch)
treecb77cd0ac80410bdcad5da21103bf0b735f9476c
parent6c79c3dae3b9737c0e1a25f0ae3906935b474725 (diff)
downloadports-6cfa70cdefcc68a5ff8afb9469c643a91cc25273.tar.gz
ports-6cfa70cdefcc68a5ff8afb9469c643a91cc25273.zip
editors/vim: Explicitly disable libcanberra support
Vim will link against libcanberra if it's installed. It really doesn't serve any particular purpose for a text editor, so it makes sense for us to just disable it explicitly. This change existed before, but was hidden in the GNOME option and got removed when libgnomeui was purged. PR: 257565 Reported by: Philipp Ost
-rw-r--r--editors/vim/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index d58e342f362e..24ed2902e873 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -2,6 +2,7 @@
PORTNAME= vim
PORTVERSION= 8.2.3273
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= editors
@@ -18,7 +19,9 @@ USE_GITHUB= yes
CONFLICTS_INSTALL?= vim-console vim-tiny
-CONFIGURE_ARGS= --enable-gui=${GUI} \
+# Vim will try to link against libcanberra if it's installed
+CONFIGURE_ARGS= --disable-canberra \
+ --enable-gui=${GUI} \
--enable-multibyte \
--with-tlib=ncursesw
MAKE_ARGS= STRIP="${STRIP_CMD}" \
@@ -33,7 +36,7 @@ PORTSCOUT= ignore:1
SHEBANG_FILES= runtime/tools/demoserver.py runtime/tools/efm_perl.pl
VIM_VER= ${PORTNAME}${PORTVERSION:R:S|.||g}
-# OPTIONS
+# OPTIONS for normal (non-tiny) vim
# ### Make sure any new options are excluded below in CONSOLE/TINY
OPTIONS_DEFAULT= CSCOPE DEFAULT_VIMRC CTAGS_EXUBERANT GTK3 PERL PYTHON RUBY
OPTIONS_DEFINE= CSCOPE DEFAULT_VIMRC MAKE_JOBS NLS XTERM_SAVE
@@ -44,9 +47,9 @@ OPTIONS_GROUP= LANGBIND
OPTIONS_GROUP_LANGBIND= LUA PERL PYTHON RUBY SCHEME TCL
OPTIONS_SUB= yes
+# vim-tiny excludes everything except CONSOLE, DEFAULT_VIMRC, MAKE_JOBS
.if defined(CONSOLE) || defined(TINY)
OPTIONS_SLAVE= CONSOLE
-# Exclude everything except CONSOLE, DEFAULT_VIMRC, MAKE_JOBS
OPTIONS_EXCLUDE:= ${OPTIONS_DEFINE:NDEFAULT_VIMRC:NMAKE_JOBS} \
${OPTIONS_SINGLE_UI:NCONSOLE} \
${OPTIONS_GROUP_LANGBIND} \