aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-05-23 03:49:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-05-23 03:49:46 +0000
commit6d18db45938d137f91e9ad23eac25559497da38e (patch)
tree01e4a30ee1edd5aec0411e496f6ebf1e10ab7d32
parent66313d16840b6346d7c6c23a5ef72ba98fb7f9ac (diff)
downloadports-6d18db45938d137f91e9ad23eac25559497da38e.tar.gz
ports-6d18db45938d137f91e9ad23eac25559497da38e.zip
graphics/gphoto2: the port had been updated to version 2.5.28
- Stop asking for GNU make, switch to smaller .tar.xz distfile - Add GitHub CDN as alternative (fallback) download location - GC no longer needed GNU_CONFIGURE_MANPREFIX and CONFIGURE_ENV - Install some more of those available documentation files - Hook the test suite to our framework (sadly, requires GNU sed) PR: 272433 Reported by: portscout
-rw-r--r--graphics/gphoto2/Makefile34
-rw-r--r--graphics/gphoto2/distinfo6
-rw-r--r--graphics/gphoto2/pkg-plist1
3 files changed, 24 insertions, 17 deletions
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index 6b3a1b218127..bf89ae384ee0 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -1,8 +1,8 @@
PORTNAME= gphoto2
-PORTVERSION= 2.5.26
-PORTREVISION= 1
+PORTVERSION= 2.5.28
CATEGORIES= graphics
-MASTER_SITES= SF/gphoto/gphoto/${PORTVERSION}
+MASTER_SITES= SF/gphoto/gphoto/${PORTVERSION} \
+ https://github.com/gphoto/gphoto2/releases/download/v${PORTVERSION}/
MAINTAINER= danfe@FreeBSD.org
COMMENT= Command-line frontend to libgphoto2
@@ -14,14 +14,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexif.so:graphics/libexif \
libgphoto2.so:graphics/libgphoto2 \
libpopt.so:devel/popt
+TEST_DEPENDS= gsed:textproc/gsed
-USES= gmake jpeg pkgconfig tar:bzip2
-
+USES= jpeg pkgconfig tar:xz
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-CONFIGURE_ENV= POPT_CFLAGS="$$(pkg-config --cflags popt)" \
- POPT_LIBS="$$(pkg-config --libs popt)"
CONFIGURE_ARGS= --without-cdk
+TEST_TARGET= check
+
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
OPTIONS_DEFINE= AALIB DOCS NLS READLINE THREADS
OPTIONS_DEFAULT= AALIB READLINE THREADS
@@ -29,14 +29,22 @@ OPTIONS_SUB= yes
AALIB_DESC= Text mode capture preview support
AALIB_LIB_DEPENDS= libaa.so:graphics/aalib
-AALIB_CONFIGURE_WITH= aalib
+AALIB_CONFIGURE_ON= --with-aalib
+
NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_OFF= --disable-nls
+
READLINE_USES= readline
-READLINE_CONFIGURE_WITH= readline
-THREADS_CONFIGURE_ENV_OFF= ac_cv_lib_pthread_pthread_exit=no
+READLINE_CONFIGURE_OFF= --without-readline
+
+THREADS_CONFIGURE_OFF= --without-pthread
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s,bash,sh,; /SEDCOMMAND/s,sed,g&,' \
+ ${WRKSRC}/tests/testsuite
post-install-DOCS-on:
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/gphoto2/distinfo b/graphics/gphoto2/distinfo
index 4eca73e0877c..e038f24da397 100644
--- a/graphics/gphoto2/distinfo
+++ b/graphics/gphoto2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611463835
-SHA256 (gphoto2-2.5.26.tar.bz2) = 7653213b05329c1dc2779efea3eff00504e12011436587aedc9aaa1e8665ab2f
-SIZE (gphoto2-2.5.26.tar.bz2) = 804521
+TIMESTAMP = 1641209289
+SHA256 (gphoto2-2.5.28.tar.xz) = ff3e32c7bd2a129d817dcd9e75ce51834409b1966e1f20e74c427c32ae732afa
+SIZE (gphoto2-2.5.28.tar.xz) = 575816
diff --git a/graphics/gphoto2/pkg-plist b/graphics/gphoto2/pkg-plist
index 6f853e6e3ef3..be7235ba9e6a 100644
--- a/graphics/gphoto2/pkg-plist
+++ b/graphics/gphoto2/pkg-plist
@@ -1,5 +1,4 @@
bin/gphoto2
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/test-hook.sh
%%NLS%%share/locale/az/LC_MESSAGES/gphoto2.mo
%%NLS%%share/locale/cs/LC_MESSAGES/gphoto2.mo