aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-30 16:07:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-30 16:10:42 +0000
commit6d28c13f73027d41d0a7e693861c2bcbe1d99309 (patch)
tree0f1cef327ef2117b1635805aba2825c8591af7e2
parentfc75da3a3b2adf1148010fe1f3cd75528387bdcc (diff)
downloadports-6d28c13f73027d41d0a7e693861c2bcbe1d99309.tar.gz
ports-6d28c13f73027d41d0a7e693861c2bcbe1d99309.zip
cad/verilator: Use GNU ar from devel/binutils
verilator requires the GNU ar feature: '@' file prefix indicating that the file contains command-line options. Reference: https://github.com/verilator/verilator/issues/2999 Reported by: Antonin Houska <ah@melesmeles.cz>
-rw-r--r--cad/verilator/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/cad/verilator/Makefile b/cad/verilator/Makefile
index 158d36ef5033..847047e51289 100644
--- a/cad/verilator/Makefile
+++ b/cad/verilator/Makefile
@@ -1,6 +1,7 @@
PORTNAME= verilator
DISTVERSIONPREFIX= v
DISTVERSION= 4.212
+PORTREVISION= 1
CATEGORIES= cad
MAINTAINER= yuri@FreeBSD.org
@@ -12,7 +13,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= see https://github.com/verilator/verilator/issues/3037
BUILD_DEPENDS= autoconf>0:devel/autoconf \
- bash:shells/bash
+ bash:shells/bash \
+ ${LOCALBASE}/bin/ar:devel/binutils
LIB_DEPENDS= libsystemc.so:devel/systemc
RUN_DEPENDS= gmake:devel/gmake # verilator runs gmake for the --hierarchical option when the 'gmake' method is chosen
@@ -23,6 +25,7 @@ SHEBANG_FILES= bin/verilator_ccache_report
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL_SCRIPT}"
+CONFIGURE_ARGS= AR=${LOCALBASE}/bin/ar
CONFIGURE_SHELL= ${LOCALBASE}/bin/bash # see https://github.com/verilator/verilator/issues/3132
TEST_TARGET= test