aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-12-29 19:30:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-01-11 16:50:06 +0000
commit6d4836a4f3407ff32cf97fa85a5bb68327052a8e (patch)
tree44862f9fef5cba1f0b09dd83b65afe6104f93935
parente0447f125a1c684146ac0b7da161d462c21d2eec (diff)
downloadports-6d4836a4f3407ff32cf97fa85a5bb68327052a8e.tar.gz
ports-6d4836a4f3407ff32cf97fa85a5bb68327052a8e.zip
games/warzone2100: fix upstream patch handling
Instead of using PATCHFILES, handle backported upstream commit as a patch under files/, where it is always available, manageable and where it doesn't break when patch format changes. Pointyhat to: jbeich
-rw-r--r--games/warzone2100/Makefile3
-rw-r--r--games/warzone2100/distinfo2
-rw-r--r--games/warzone2100/files/patch-5e6fdab49
3 files changed, 49 insertions, 5 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index a21f4cccc585..c3b1e1026a28 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -6,9 +6,6 @@ MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}_src
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
-PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}/commit/
-PATCHFILES+= 5e6fdab3feac.patch:-p1 # https://github.com/Warzone2100/warzone2100/pull/2479
-
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Innovative 3D real-time strategy game
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
index 0911f8249158..ea2ee87491e0 100644
--- a/games/warzone2100/distinfo
+++ b/games/warzone2100/distinfo
@@ -1,5 +1,3 @@
TIMESTAMP = 1618939913
SHA256 (warzone2100-4.0.1/warzone2100_src.tar.xz) = 337622d5f813bbc1f9a3b4fee0874fcc074806781cfa9c25a252534ddd240ab9
SIZE (warzone2100-4.0.1/warzone2100_src.tar.xz) = 337713608
-SHA256 (warzone2100-4.0.1/5e6fdab3feac.patch) = 579ffd85c09ffca615a9c90cb07d1021d7dc58fe12dffed8c7e5602cdaa8ca7d
-SIZE (warzone2100-4.0.1/5e6fdab3feac.patch) = 1737
diff --git a/games/warzone2100/files/patch-5e6fdab b/games/warzone2100/files/patch-5e6fdab
new file mode 100644
index 000000000000..4b9e4fb8ed99
--- /dev/null
+++ b/games/warzone2100/files/patch-5e6fdab
@@ -0,0 +1,49 @@
+From 5e6fdab3feac55357bcaedcb03ef619d23d3277f Mon Sep 17 00:00:00 2001
+From: past-due <30942300+past-due@users.noreply.github.com>
+Date: Sat, 4 Dec 2021 11:22:24 -0500
+Subject: [PATCH] [Vulkan] Add missing vk:: namespace to `throwResultException`
+
+---
+ lib/ivis_opengl/gfx_api_vk.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/lib/ivis_opengl/gfx_api_vk.cpp b/lib/ivis_opengl/gfx_api_vk.cpp
+index 594d127f70..419b8a7644 100644
+--- lib/ivis_opengl/gfx_api_vk.cpp
++++ lib/ivis_opengl/gfx_api_vk.cpp
+@@ -477,7 +477,7 @@ void BlockBufferAllocator::allocateNewBlock(uint32_t minimumSize)
+ if (result != vk::Result::eSuccess)
+ {
+ // Failed to allocate memory!
+- throwResultException( result, "vmaCreateBuffer" );
++ vk::throwResultException( result, "vmaCreateBuffer" );
+ }
+
+ if (autoMap)
+@@ -1304,7 +1304,7 @@ VkPSO::VkPSO(vk::Device _dev,
+ object = std::move(result.value);
+ break;
+ default:
+- throwResultException(result.result, "createGraphicsPipeline");
++ vk::throwResultException(result.result, "createGraphicsPipeline");
+ }
+ }
+
+@@ -1368,7 +1368,7 @@ void VkBuf::allocateBufferObject(const std::size_t& size)
+ if (result != vk::Result::eSuccess)
+ {
+ // Failed to allocate memory!
+- throwResultException( result, "vmaCreateBuffer" );
++ vk::throwResultException( result, "vmaCreateBuffer" );
+ }
+
+ buffer_size = size;
+@@ -1486,7 +1486,7 @@ VkTexture::VkTexture(const VkRoot& root, const std::size_t& mipmap_count, const
+ if (result != vk::Result::eSuccess)
+ {
+ // Failed to allocate memory!
+- throwResultException( result, "vmaCreateImage" );
++ vk::throwResultException( result, "vmaCreateImage" );
+ }
+
+ const auto imageViewCreateInfo = vk::ImageViewCreateInfo()