aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStéphane D'Alu <sdalu@sdalu.com>2022-03-23 12:56:05 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2022-03-23 13:05:26 +0000
commit6d584ad463b6c0a3bb037f1a4c78aa9b62b76af9 (patch)
tree4eddcaeef34a98f7d7b1128ea33b24e0b7e6fed2
parent6b43c5812ed616a7fd4b28dcfa58b30232fa7b04 (diff)
downloadports-6d584ad463b6c0a3bb037f1a4c78aa9b62b76af9.tar.gz
ports-6d584ad463b6c0a3bb037f1a4c78aa9b62b76af9.zip
devel/rubygem-memo_wise: Add new port
Add devel/rubygem-memo_wise, the wise choice for Ruby memoization. * Fast performance of memoized reads (with benchmarks) * Support for resetting and presetting memoized values * Support for memoization on frozen objects * Support for memoization of class and module methods * Support for inheritance of memoized class and instance methods * Documented and tested thread-safety guarantees * Full documentation and test coverage! WWW: https://github.com/panorama-ed/memo_wise PR: 262553
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-memo_wise/Makefile16
-rw-r--r--devel/rubygem-memo_wise/distinfo3
-rw-r--r--devel/rubygem-memo_wise/pkg-descr11
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 865905053cfb..8b4793736c29 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6526,6 +6526,7 @@
SUBDIR += rubygem-manpages
SUBDIR += rubygem-map
SUBDIR += rubygem-marcel
+ SUBDIR += rubygem-memo_wise
SUBDIR += rubygem-memoist
SUBDIR += rubygem-memoizable
SUBDIR += rubygem-memoize
diff --git a/devel/rubygem-memo_wise/Makefile b/devel/rubygem-memo_wise/Makefile
new file mode 100644
index 000000000000..cbaa61551a05
--- /dev/null
+++ b/devel/rubygem-memo_wise/Makefile
@@ -0,0 +1,16 @@
+PORTNAME= memo_wise
+DISTVERSION= 1.6.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sdalu@sdalu.com
+COMMENT= Support for memoizing functions
+
+LICENSE= MIT
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-memo_wise/distinfo b/devel/rubygem-memo_wise/distinfo
new file mode 100644
index 000000000000..2c1766ff1d1e
--- /dev/null
+++ b/devel/rubygem-memo_wise/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1647262208
+SHA256 (rubygem/memo_wise-1.6.0.gem) = 659428463c841fdd47e267d78f127345ec1d03529d75c3c817d99b8789ad6dc5
+SIZE (rubygem/memo_wise-1.6.0.gem) = 174080
diff --git a/devel/rubygem-memo_wise/pkg-descr b/devel/rubygem-memo_wise/pkg-descr
new file mode 100644
index 000000000000..8ac49a5ba750
--- /dev/null
+++ b/devel/rubygem-memo_wise/pkg-descr
@@ -0,0 +1,11 @@
+The wise choice for Ruby memoization.
+
+* Fast performance of memoized reads (with benchmarks)
+* Support for resetting and presetting memoized values
+* Support for memoization on frozen objects
+* Support for memoization of class and module methods
+* Support for inheritance of memoized class and instance methods
+* Documented and tested thread-safety guarantees
+* Full documentation and test coverage!
+
+WWW: https://github.com/panorama-ed/memo_wise