aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormew14930xvi <mew14930xvi@inbox.lv>2024-03-26 01:44:10 +0000
committerGabriel M. Dutra <dutra@FreeBSD.org>2024-03-26 01:52:17 +0000
commit6db9adf118c2e37c5c3464ec44fcbca362a41c14 (patch)
tree66e928394847c3f7d61342d710f7f45005b49900
parent9ee7b88dab0568e341a09813bd2a8b60009171d6 (diff)
downloadports-6db9adf118c2e37c5c3464ec44fcbca362a41c14.tar.gz
ports-6db9adf118c2e37c5c3464ec44fcbca362a41c14.zip
net-mgmt/tcpreplay: Update to 4.4.4
changeLog: https://github.com/appneta/tcpreplay/releases/tag/v4.4.4 PR: 277924 Reported by: mew14930xvi <mew14930xvi@inbox.lv> Approved by: garga (mentor, implicit)
-rw-r--r--net-mgmt/tcpreplay/Makefile6
-rw-r--r--net-mgmt/tcpreplay/distinfo6
-rw-r--r--net-mgmt/tcpreplay/files/patch-Makefile.in11
-rw-r--r--net-mgmt/tcpreplay/files/patch-lib_queue.h19
-rw-r--r--net-mgmt/tcpreplay/files/patch-src__tree.c11
5 files changed, 23 insertions, 30 deletions
diff --git a/net-mgmt/tcpreplay/Makefile b/net-mgmt/tcpreplay/Makefile
index 618bc07b0fe6..58a1843c0602 100644
--- a/net-mgmt/tcpreplay/Makefile
+++ b/net-mgmt/tcpreplay/Makefile
@@ -1,6 +1,5 @@
PORTNAME= tcpreplay
-DISTVERSION= 4.4.3
-PORTREVISION= 1
+DISTVERSION= 4.4.4
CATEGORIES= net-mgmt
MASTER_SITES= https://github.com/appneta/${PORTNAME}/releases/download/v${DISTVERSION}/
@@ -27,9 +26,6 @@ CONFIGURE_ARGS= --disable-libopts-install \
TEST_TARGET= test
-# https://github.com/appneta/tcpreplay/issues/809
-PORTSCOUT= skipv:4.4.4
-
OPTIONS_DEFAULT= LIBPCAP_BASE
OPTIONS_SINGLE= LIBPCAP
OPTIONS_SINGLE_LIBPCAP= LIBPCAP_BASE LIBPCAP_PORTS
diff --git a/net-mgmt/tcpreplay/distinfo b/net-mgmt/tcpreplay/distinfo
index f5e9897f6040..005bc40f5f01 100644
--- a/net-mgmt/tcpreplay/distinfo
+++ b/net-mgmt/tcpreplay/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1672658688
-SHA256 (tcpreplay-4.4.3.tar.xz) = 352fcd073c61140e5008ffe4e37d4744c31037e73854a921cd8b6b5d9f29cd54
-SIZE (tcpreplay-4.4.3.tar.xz) = 750072
+TIMESTAMP = 1711299300
+SHA256 (tcpreplay-4.4.4.tar.xz) = 3ff9753cc43bb15e77832cee657e3030dbcdd957fa247e6abacc605689e24051
+SIZE (tcpreplay-4.4.4.tar.xz) = 748344
diff --git a/net-mgmt/tcpreplay/files/patch-Makefile.in b/net-mgmt/tcpreplay/files/patch-Makefile.in
deleted file mode 100644
index 2c1aeee9e5e1..000000000000
--- a/net-mgmt/tcpreplay/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2022-02-05 21:30:36 UTC
-+++ Makefile.in
-@@ -892,7 +892,7 @@ autoopts:
-
- test:
- echo Making test in $(TEST_DIR)
-- cd $(TEST_DIR) && make test
-+ cd $(TEST_DIR) && gmake test
-
- dlt_names:
- cat @SAVEFILE_C@ | $(top_builddir)/scripts/dlt2name.pl src/dlt_names.h
diff --git a/net-mgmt/tcpreplay/files/patch-lib_queue.h b/net-mgmt/tcpreplay/files/patch-lib_queue.h
new file mode 100644
index 000000000000..cc17718f57a1
--- /dev/null
+++ b/net-mgmt/tcpreplay/files/patch-lib_queue.h
@@ -0,0 +1,19 @@
+--- lib/queue.h.orig 2024-03-24 16:55:28 UTC
++++ lib/queue.h
+@@ -36,8 +36,8 @@
+ * @(#)queue.h 8.5 (Berkeley) 8/20/94
+ */
+
+-#ifndef _SYS_QUEUE_H_
+-#define _SYS_QUEUE_H_
++#ifndef _QUEUE_H_
++#define _QUEUE_H_
+
+ /*
+ * This file defines five types of data structures: singly-linked lists,
+@@ -508,4 +508,4 @@ struct { \
+ (elm2)->field.cqe_prev->field.cqe_next = (elm2); \
+ } while (0)
+
+-#endif /* !_SYS_QUEUE_H_ */
++#endif /* !_QUEUE_H_ */
diff --git a/net-mgmt/tcpreplay/files/patch-src__tree.c b/net-mgmt/tcpreplay/files/patch-src__tree.c
deleted file mode 100644
index da859df388e8..000000000000
--- a/net-mgmt/tcpreplay/files/patch-src__tree.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tree.c.orig 2016-11-19 19:41:38 UTC
-+++ src/tree.c
-@@ -37,6 +37,8 @@ extern tcpprep_t *tcpprep;
- extern int debug;
- #endif
-
-+#include <sys/socket.h>
-+
- /* static buffer used by tree_print*() functions */
- char tree_print_buff[TREEPRINTBUFFLEN];
-