aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2022-02-21 16:13:50 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2022-02-22 11:25:31 +0000
commit6e093a0b43ca58f85fe80135bab2f6c9c87b8fb1 (patch)
tree6fe65c482ce2907f6135230e5cc84c9eb2f93fe4
parent26c7cd14084c9cbd570963f9b9ebe3e2e6ec7f9e (diff)
downloadports-6e093a0b43ca58f85fe80135bab2f6c9c87b8fb1.tar.gz
ports-6e093a0b43ca58f85fe80135bab2f6c9c87b8fb1.zip
devel/R-cran-hardhat: Add new port
Building modeling packages is hard. A large amount of effort generally goes into providing an implementation for a new method that is efficient, fast, and correct, but often less emphasis is put on the user interface. A good interface requires specialized knowledge about S3 methods and formulas, which the average package developer might not have. The goal of 'hardhat' is to reduce the burden around building new modeling packages by providing functionality for preprocessing, predicting, and validating input. WWW: https://cran.r-project.org/web/packages/hardhat/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-hardhat/Makefile20
-rw-r--r--devel/R-cran-hardhat/distinfo3
-rw-r--r--devel/R-cran-hardhat/pkg-descr10
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index be215f29466e..1674ae7ea3b1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -62,6 +62,7 @@
SUBDIR += R-cran-gmodels
SUBDIR += R-cran-gsubfn
SUBDIR += R-cran-gtools
+ SUBDIR += R-cran-hardhat
SUBDIR += R-cran-hms
SUBDIR += R-cran-ini
SUBDIR += R-cran-iterators
diff --git a/devel/R-cran-hardhat/Makefile b/devel/R-cran-hardhat/Makefile
new file mode 100644
index 000000000000..c1f5ba50bea5
--- /dev/null
+++ b/devel/R-cran-hardhat/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= hardhat
+PORTVERSION= 0.2.0
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Construct Modeling Packages
+
+LICENSE= MIT
+
+CRAN_DEPENDS= R-cran-glue>0:devel/R-cran-glue \
+ R-cran-rlang>=0.4.2:devel/R-cran-rlang \
+ R-cran-tibble>0:devel/R-cran-tibble \
+ R-cran-vctrs>=0.3.0:devel/R-cran-vctrs
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-hardhat/distinfo b/devel/R-cran-hardhat/distinfo
new file mode 100644
index 000000000000..5b905f835fa9
--- /dev/null
+++ b/devel/R-cran-hardhat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1645406750
+SHA256 (hardhat_0.2.0.tar.gz) = 9497ca0fe6206c54d1da79f248d44c5faffc7d375b630091ef45dfca46c29628
+SIZE (hardhat_0.2.0.tar.gz) = 898777
diff --git a/devel/R-cran-hardhat/pkg-descr b/devel/R-cran-hardhat/pkg-descr
new file mode 100644
index 000000000000..ef704a5d4254
--- /dev/null
+++ b/devel/R-cran-hardhat/pkg-descr
@@ -0,0 +1,10 @@
+Building modeling packages is hard. A large amount of effort generally
+goes into providing an implementation for a new method that is
+efficient, fast, and correct, but often less emphasis is put on the
+user interface. A good interface requires specialized knowledge
+about S3 methods and formulas, which the average package developer
+might not have. The goal of 'hardhat' is to reduce the burden around
+building new modeling packages by providing functionality for
+preprocessing, predicting, and validating input.
+
+WWW: https://cran.r-project.org/web/packages/hardhat/