aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Turgeon <ericbsd@FreeBSD.org>2021-08-04 11:06:01 +0000
committerEric Turgeon <ericbsd@FreeBSD.org>2021-08-04 11:09:31 +0000
commit6e8b0bf4a52a2a12471533bb9b7ffd448d5d8d84 (patch)
treeab67f99897fce2bc8a4fd99c603e638cddd71039
parent62329a89eaa534aa5bf12131f624be4edbd060a5 (diff)
downloadports-6e8b0bf4a52a2a12471533bb9b7ffd448d5d8d84.tar.gz
ports-6e8b0bf4a52a2a12471533bb9b7ffd448d5d8d84.zip
x11/xfce4-appmenu-plugin: new port
This is an Application Menu applet providing Global Menu for the XFCE panel
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xfce4-appmenu-plugin/Makefile34
-rw-r--r--x11/xfce4-appmenu-plugin/distinfo3
-rw-r--r--x11/xfce4-appmenu-plugin/files/patch-lib_dbusmenu-importer_importer.c11
-rw-r--r--x11/xfce4-appmenu-plugin/files/patch-meson.build8
-rw-r--r--x11/xfce4-appmenu-plugin/files/patch-subprojects_appmenu-gtk-module_src_datastructs-private.h11
-rw-r--r--x11/xfce4-appmenu-plugin/pkg-descr3
-rw-r--r--x11/xfce4-appmenu-plugin/pkg-message18
-rw-r--r--x11/xfce4-appmenu-plugin/pkg-plist2
9 files changed, 91 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index f5713972a776..880559ceb7c6 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -450,6 +450,7 @@
SUBDIR += xev
SUBDIR += xeyes
SUBDIR += xf86dga
+ SUBDIR += xfce4-appmenu-plugin
SUBDIR += xfce4-clipman-plugin
SUBDIR += xfce4-conf
SUBDIR += xfce4-dashboard
diff --git a/x11/xfce4-appmenu-plugin/Makefile b/x11/xfce4-appmenu-plugin/Makefile
new file mode 100644
index 000000000000..531ae3c6ac72
--- /dev/null
+++ b/x11/xfce4-appmenu-plugin/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= xfce4-appmenu-plugin
+DISTVERSION= 0.7.6
+CATEGORIES= x11
+
+MAINTAINER= ericbsd@FreeBSD.org
+COMMENT= Application Menu plugin for XFCE panel
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libbamf3.so:sysutils/bamf
+BUILD_DEPENDS= valac:lang/vala
+RUN_DEPENDS= appmenu-registrar>=0:x11/appmenu-registrar \
+ appmenu-gtk-module>=0:x11/gtk-app-menu
+
+USES= meson gnome xfce pkgconfig gettext
+
+MESON_ARGS= -Dvalapanel=disabled \
+ -Dxfce=enabled \
+ -Dmate=disabled \
+ -Dbudgie=disabled \
+ -Djayatana=disabled \
+ -Dregistrar=disabled \
+ -Dappmenu-gtk-module=disabled
+
+USE_XFCE= panel
+USE_GNOME= gtk30 glib20 gtk20 gdkpixbuf2
+
+USE_GITLAB= yes
+GL_ACCOUNT= vala-panel-project
+GL_PROJECT= vala-panel-appmenu
+GL_COMMIT= 4e362c22ab3a23c98f13fb379c782786ee057cf6
+
+.include <bsd.port.mk>
diff --git a/x11/xfce4-appmenu-plugin/distinfo b/x11/xfce4-appmenu-plugin/distinfo
new file mode 100644
index 000000000000..063974a98247
--- /dev/null
+++ b/x11/xfce4-appmenu-plugin/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1617892721
+SHA256 (vala-panel-project-vala-panel-appmenu-4e362c22ab3a23c98f13fb379c782786ee057cf6_GL0.tar.gz) = 374ee0bd840ae1e78891ca1dd97ea25ebabec929e5eaec8dc16ae8f8e7680b67
+SIZE (vala-panel-project-vala-panel-appmenu-4e362c22ab3a23c98f13fb379c782786ee057cf6_GL0.tar.gz) = 149765
diff --git a/x11/xfce4-appmenu-plugin/files/patch-lib_dbusmenu-importer_importer.c b/x11/xfce4-appmenu-plugin/files/patch-lib_dbusmenu-importer_importer.c
new file mode 100644
index 000000000000..c36a53d3b3e3
--- /dev/null
+++ b/x11/xfce4-appmenu-plugin/files/patch-lib_dbusmenu-importer_importer.c
@@ -0,0 +1,11 @@
+--- lib/dbusmenu-importer/importer.c.orig 2021-01-01 20:18:10 UTC
++++ lib/dbusmenu-importer/importer.c
+@@ -25,7 +25,7 @@ struct _DBusMenuImporter
+ GObject parent_instance;
+ char *bus_name;
+ char *object_path;
+- ulong name_id;
++ gulong name_id;
+ GCancellable *cancellable;
+ DBusMenuXml *proxy;
+ DBusMenuModel *top_model;
diff --git a/x11/xfce4-appmenu-plugin/files/patch-meson.build b/x11/xfce4-appmenu-plugin/files/patch-meson.build
new file mode 100644
index 000000000000..4ff6b1ce2cbd
--- /dev/null
+++ b/x11/xfce4-appmenu-plugin/files/patch-meson.build
@@ -0,0 +1,8 @@
+--- meson.build.orig 2021-01-02 21:06:31 UTC
++++ meson.build
+@@ -117,4 +117,4 @@ readmes = [
+ 'README.md',
+ 'LICENSE',
+ ]
+-install_data(readmes, install_dir : join_paths(get_option('datadir'), meson.project_name(), 'doc'))
++# install_data(readmes, install_dir : join_paths(get_option('datadir'), meson.project_name(), 'doc'))
diff --git a/x11/xfce4-appmenu-plugin/files/patch-subprojects_appmenu-gtk-module_src_datastructs-private.h b/x11/xfce4-appmenu-plugin/files/patch-subprojects_appmenu-gtk-module_src_datastructs-private.h
new file mode 100644
index 000000000000..5e5f620d955c
--- /dev/null
+++ b/x11/xfce4-appmenu-plugin/files/patch-subprojects_appmenu-gtk-module_src_datastructs-private.h
@@ -0,0 +1,11 @@
+--- subprojects/appmenu-gtk-module/src/datastructs-private.h.orig 2019-03-02 16:23:40 UTC
++++ subprojects/appmenu-gtk-module/src/datastructs-private.h
+@@ -31,7 +31,7 @@
+ struct _WindowData
+ {
+ uint window_id;
+- ulong wayland_window_id;
++ gulong wayland_window_id;
+ GMenu *menu_model;
+ guint menu_model_export_id;
+ GSList *menus;
diff --git a/x11/xfce4-appmenu-plugin/pkg-descr b/x11/xfce4-appmenu-plugin/pkg-descr
new file mode 100644
index 000000000000..5a3005ccdcd3
--- /dev/null
+++ b/x11/xfce4-appmenu-plugin/pkg-descr
@@ -0,0 +1,3 @@
+This is an Application Menu applet providing Global Menu for the XFCE panel.
+
+WWW: https://gitlab.com/vala-panel-project/vala-panel-appmenu
diff --git a/x11/xfce4-appmenu-plugin/pkg-message b/x11/xfce4-appmenu-plugin/pkg-message
new file mode 100644
index 000000000000..6fbe5c88d3d9
--- /dev/null
+++ b/x11/xfce4-appmenu-plugin/pkg-message
@@ -0,0 +1,18 @@
+[
+{
+ message: <<EOD
+When using the panel appmenu as an XFCE menu applet, you have to configure
+the appmenu to show in the panel applet, rather than on each individual window.
+
+This configuration should remove any 'double' menus you may experience:
+
+# xfconf-query -c xsettings -p /Gtk/ShellShowsMenubar -n -t bool -s true
+# xfconf-query -c xsettings -p /Gtk/ShellShowsAppmenu -n -t bool -s true
+
+This configuration will load the appmenu-gtk-module for XFCE:
+
+# xfconf-query -c xsettings -p /Gtk/Modules -n -t string -s "appmenu-gtk-module"
+EOD,
+ type: install
+}
+]
diff --git a/x11/xfce4-appmenu-plugin/pkg-plist b/x11/xfce4-appmenu-plugin/pkg-plist
new file mode 100644
index 000000000000..5b4cd2070253
--- /dev/null
+++ b/x11/xfce4-appmenu-plugin/pkg-plist
@@ -0,0 +1,2 @@
+lib/xfce4/panel/plugins/libappmenu-xfce.so
+share/xfce4/panel/plugins/appmenu.desktop