aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-03-27 21:12:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-03-27 21:17:50 +0000
commit6e98271eb57db88b3b6582c1645445cb075213e0 (patch)
tree55a94e5b9d1834994ad495e95a414bf18bd22287
parent3abae5ee274a989bd3f39566bb3554193d4c9653 (diff)
downloadports-6e98271eb57db88b3b6582c1645445cb075213e0.tar.gz
ports-6e98271eb57db88b3b6582c1645445cb075213e0.zip
graphics/libjxl: unbreak on riscv64 after 32c2b95c682e
Hard-float 'd' ABI can't be used for a target that doesn't support the D instruction set extension (ignoring target-abi) ld: error: too many errors emitted, stopping now (use -error-limit=0 to see all errors) c++: error: linker command failed with exit code 1 (use -v to see invocation) Reported by: pkg-fallout
-rw-r--r--graphics/libjxl/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/libjxl/Makefile b/graphics/libjxl/Makefile
index ef51f97e982f..edb035777cdf 100644
--- a/graphics/libjxl/Makefile
+++ b/graphics/libjxl/Makefile
@@ -42,6 +42,7 @@ OPTIONS_DEFINE= GIF JPEG LTO MANPAGES OPENEXR PIXBUF PNG
OPTIONS_DEFAULT=GIF JPEG LTO MANPAGES OPENEXR PIXBUF PNG
OPTIONS_EXCLUDE_i386= LTO # ConvolutionWithTranspose(): JXL_CHECK: out->xsize() == in.ysize()
OPTIONS_EXCLUDE_powerpc64= ${"${/usr/bin/ld:L:tA}"==/usr/bin/ld.lld:?LTO:} # https://github.com/llvm/llvm-project/issues/46697
+OPTIONS_EXCLUDE_riscv64= LTO # bug 262871
OPTIONS_SUB= yes
GIF_LIB_DEPENDS= libgif.so:graphics/giflib