aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-09 21:02:44 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-09 21:02:57 +0000
commit6ea16be52d9ff5c4836db94c8ec93da5c956c895 (patch)
tree646404728217ca41dcad7de280683bb5eaeef8e9
parent3e7fba0271a6162ef8683dbd24e04a41a813cab7 (diff)
downloadports-6ea16be52d9ff5c4836db94c8ec93da5c956c895.tar.gz
ports-6ea16be52d9ff5c4836db94c8ec93da5c956c895.zip
sysutils/py-liquidctl: Update to 1.9.1
-rw-r--r--sysutils/py-liquidctl/Makefile3
-rw-r--r--sysutils/py-liquidctl/distinfo6
-rw-r--r--sysutils/py-liquidctl/files/patch-setup.py7
3 files changed, 12 insertions, 4 deletions
diff --git a/sysutils/py-liquidctl/Makefile b/sysutils/py-liquidctl/Makefile
index 362dd57082b0..7dd203424886 100644
--- a/sysutils/py-liquidctl/Makefile
+++ b/sysutils/py-liquidctl/Makefile
@@ -1,7 +1,7 @@
# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
PORTNAME= liquidctl
-PORTVERSION= 1.8.1
+PORTVERSION= 1.9.1
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,6 +12,7 @@ COMMENT= Cross-platform tool and drivers for liquid coolers and other devices
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorlog>=0:devel/py-colorlog@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}docopt>=0:devel/py-docopt@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}hidapi>=0.10.1:comms/py-hidapi@${PY_FLAVOR} \
diff --git a/sysutils/py-liquidctl/distinfo b/sysutils/py-liquidctl/distinfo
index a98ca2689897..14843a1e7d50 100644
--- a/sysutils/py-liquidctl/distinfo
+++ b/sysutils/py-liquidctl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1642786623
-SHA256 (liquidctl-1.8.1.tar.gz) = 0859dfe673babe9af10e4f431e0baa974961f0b2c973a37e64eb6c6c2fddbe73
-SIZE (liquidctl-1.8.1.tar.gz) = 1782665
+TIMESTAMP = 1649517213
+SHA256 (liquidctl-1.9.1.tar.gz) = b4467e842d9a6adc804317a991354db041417f4f7dcf7d76799f2b1593ed1276
+SIZE (liquidctl-1.9.1.tar.gz) = 1800635
diff --git a/sysutils/py-liquidctl/files/patch-setup.py b/sysutils/py-liquidctl/files/patch-setup.py
new file mode 100644
index 000000000000..e46bc382cd21
--- /dev/null
+++ b/sysutils/py-liquidctl/files/patch-setup.py
@@ -0,0 +1,7 @@
+--- setup.py.orig 2022-04-09 15:13:54 UTC
++++ setup.py
+@@ -0,0 +1,4 @@
++from setuptools import setup
++
++if __name__ == "__main__":
++ setup()