aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-27 04:51:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-27 04:52:40 +0000
commit6ed61c3042c007c7b4500a27ad156bd8047cb4d3 (patch)
tree85be5accaedf9c3970c557036e32f54367f255a0
parent8744877af2ad6b865266551667df28489b02f59d (diff)
downloadports-6ed61c3042c007c7b4500a27ad156bd8047cb4d3.tar.gz
ports-6ed61c3042c007c7b4500a27ad156bd8047cb4d3.zip
science/dimod: New port: DWave: Shared API for QUBO/Ising samplers
-rw-r--r--science/Makefile1
-rw-r--r--science/dimod/Makefile34
-rw-r--r--science/dimod/distinfo5
-rw-r--r--science/dimod/pkg-descr11
4 files changed, 51 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index a67584509e4d..28e271d2ba1b 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -69,6 +69,7 @@
SUBDIR += devisor
SUBDIR += dftbplus
SUBDIR += dftd4
+ SUBDIR += dimod
SUBDIR += dirac
SUBDIR += dkh
SUBDIR += dlib-cpp
diff --git a/science/dimod/Makefile b/science/dimod/Makefile
new file mode 100644
index 000000000000..7769889eac1e
--- /dev/null
+++ b/science/dimod/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= dimod
+DISTVERSION= 0.11.5
+CATEGORIES= science python
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DWave: Shared API for QUBO/Ising samplers
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.7+
+
+USE_GITHUB= yes
+GH_ACCOUNT= dwavesystems
+GH_TUPLE= catchorg:Catch2:f0dc4d9:catch/testscpp/Catch2
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/dimod/iterators.h \
+ include/dimod/lp.h \
+ include/dimod/quadratic_model.h \
+ include/dimod/utils.h
+
+BINARY_ALIAS= g++=${CXX} git=true
+
+do-install:
+ @cd ${WRKSRC}/dimod/include && \
+ ${COPYTREE_SHARE} dimod ${STAGEDIR}${PREFIX}/include
+
+do-test: # tests fail to compile, see https://github.com/dwavesystems/dimod/issues/1238
+ cd ${WRKSRC}/testscpp && ${SETENV} ${MAKE_ENV} ${MAKE}
+
+.include <bsd.port.mk>
diff --git a/science/dimod/distinfo b/science/dimod/distinfo
new file mode 100644
index 000000000000..cdecb040478e
--- /dev/null
+++ b/science/dimod/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1661575588
+SHA256 (dwavesystems-dimod-0.11.5_GH0.tar.gz) = 8602da849ed8ae13d48eb0507d4107b2037d072a53652673ab108bb5772f443b
+SIZE (dwavesystems-dimod-0.11.5_GH0.tar.gz) = 520765
+SHA256 (catchorg-Catch2-f0dc4d9_GH0.tar.gz) = 2fed775decd4fa7adbfb193d2e80a2937e3eaaeef2f5b0633ec21449995ff77d
+SIZE (catchorg-Catch2-f0dc4d9_GH0.tar.gz) = 651357
diff --git a/science/dimod/pkg-descr b/science/dimod/pkg-descr
new file mode 100644
index 000000000000..dcaf688769da
--- /dev/null
+++ b/science/dimod/pkg-descr
@@ -0,0 +1,11 @@
+dimod is a part of the software stack for accessing quantum computing hardware
+made by D-Wave company.
+
+dimod is a shared API for samplers. It provides:
+* classes for quadratic models - such as the binary quadratic model (BQM) class
+ that contains Ising and QUBO models used by samplers such as the D-Wave system
+ - and higher-order (non-quadratic) models
+* reference examples of samplers and composed samplers
+* abstract base classes for constructing new samplers and composed samplers
+
+WWW: https://github.com/dwavesystems/dimod