aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2023-05-30 13:57:03 +0000
committerJuraj Lutter <otis@FreeBSD.org>2023-05-30 13:58:27 +0000
commit6f25b5a4e9ace69e85390d02ae6587b72ebe9e15 (patch)
tree5fd883ba73c55d911ce8d0ffc2a7a52b434f77b3
parent81dde2a06238b00aa9a030281752812e10fcad16 (diff)
downloadports-6f25b5a4e9ace69e85390d02ae6587b72ebe9e15.tar.gz
ports-6f25b5a4e9ace69e85390d02ae6587b72ebe9e15.zip
misc/trurl: Update to 0.7
- Update to 0.7 - Honor global CFLAGS and LDFLAGS - Introduce "test" target (based on [1]) PR: 270770 [1]
-rw-r--r--misc/trurl/Makefile16
-rw-r--r--misc/trurl/distinfo6
-rw-r--r--misc/trurl/files/patch-Makefile11
3 files changed, 26 insertions, 7 deletions
diff --git a/misc/trurl/Makefile b/misc/trurl/Makefile
index 0159d2c61ace..47ad3cda8c80 100644
--- a/misc/trurl/Makefile
+++ b/misc/trurl/Makefile
@@ -1,6 +1,6 @@
PORTNAME= trurl
DISTVERSIONPREFIX= ${PORTNAME}-
-DISTVERSION= 0.6
+DISTVERSION= 0.7
CATEGORIES= misc www
MAINTAINER= otis@FreeBSD.org
@@ -11,16 +11,24 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>0:devel/py-packaging@${PY_FLAVOR}
+USES= python:test
USE_GITHUB= yes
GH_ACCOUNT= curl
-MAKE_ARGS= CFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ARGS= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-lcurl" \
+ LDLIBS="-L${LOCALBASE}/lib" \
+ MANDIR="${PREFIX}/man/man1"
ALL_TARGET= ${PORTNAME}
+TEST_TARGET= test
PLIST_FILES= bin/trurl \
- share/man/man1/trurl.1.gz
+ man/man1/trurl.1.gz
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/trurl
.include <bsd.port.mk>
diff --git a/misc/trurl/distinfo b/misc/trurl/distinfo
index cd53110eb60c..c6984dae7e7c 100644
--- a/misc/trurl/distinfo
+++ b/misc/trurl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1682851129
-SHA256 (curl-trurl-trurl-0.6_GH0.tar.gz) = 4564dff7441d33a29aa02fe64bea7ef0809d9fabc1609ac5b50ca5503e81caa6
-SIZE (curl-trurl-trurl-0.6_GH0.tar.gz) = 30517
+TIMESTAMP = 1685349895
+SHA256 (curl-trurl-trurl-0.7_GH0.tar.gz) = 11616a4c3d255ff3347cb8fc65ea4f890526f327800ec556d78e88881e2cbfa7
+SIZE (curl-trurl-trurl-0.7_GH0.tar.gz) = 36624
diff --git a/misc/trurl/files/patch-Makefile b/misc/trurl/files/patch-Makefile
new file mode 100644
index 000000000000..d39f001fab57
--- /dev/null
+++ b/misc/trurl/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2023-05-29 09:11:15 UTC
++++ Makefile
+@@ -1,7 +1,6 @@
+ TARGET = trurl
+ OBJS = trurl.o
+-LDLIBS = $$(curl-config --libs)
+-CFLAGS = $$(curl-config --cflags) -W -Wall -Wshadow -Werror -pedantic -g
++CFLAGS+=-W -Wall -Wshadow -Werror -pedantic -g
+ MANUAL = trurl.1
+
+ PREFIX ?= /usr/local