aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2022-11-02 08:28:31 +0000
committerThomas Zander <riggs@FreeBSD.org>2022-11-02 21:50:38 +0000
commit6ff8606f00d2d368d6dd2d3e7535d1c1525f59bf (patch)
tree39d39a2f18572257079dfc18275e358a6a47fa49
parent78c074896f66ec0ff90e9e714608d8d0bccf5ca3 (diff)
downloadports-6ff8606f00d2d368d6dd2d3e7535d1c1525f59bf.tar.gz
ports-6ff8606f00d2d368d6dd2d3e7535d1c1525f59bf.zip
multimedia/gstreamer1-*: Fix plugin building in dirty environments
This should solve (fingers crossed) the meson autodetection problem for the remaining plugins from the "bad" set when building in dirty environments. PR: 267132, 267510
-rw-r--r--multimedia/gstreamer1-plugins-dts/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common2
2 files changed, 3 insertions, 1 deletions
diff --git a/multimedia/gstreamer1-plugins-dts/Makefile b/multimedia/gstreamer1-plugins-dts/Makefile
index a5809ef8af99..54d0cf07021d 100644
--- a/multimedia/gstreamer1-plugins-dts/Makefile
+++ b/multimedia/gstreamer1-plugins-dts/Makefile
@@ -14,4 +14,4 @@ LIB_DEPENDS= libdca.so:multimedia/libdca
.include "${MASTERDIR}/Makefile"
-MESON_ARGS+= -Dgpl=enabled -Dv4l2codecs=disabled -Dsvthevcenc=disabled
+MESON_ARGS+= -Dgpl=enabled
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index 6a43434bd79b..0a95d4a31455 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -180,6 +180,7 @@ BAD_GST_ALL_PLUGINS+= \
speed \
srtp \
subenc \
+ svthevcenc \
switchbin \
tests \
timecode \
@@ -190,6 +191,7 @@ BAD_GST_ALL_PLUGINS+= \
ttml \
uridownloader \
uvch264 \
+ v4l2codecs \
videofilters \
videoframe_audiolevel \
videoparsers \