aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-07-18 14:33:23 +0000
committerCy Schubert <cy@FreeBSD.org>2023-07-18 14:56:40 +0000
commit7187c760db69985124457decf7aa7997fa141fc0 (patch)
tree142183f781b2b7789d1ba362fa8cd81b2e9145f7
parent5ba8ffefe59e7d478164fcacaae5e5aa720c402c (diff)
downloadports-7187c760db69985124457decf7aa7997fa141fc0.tar.gz
ports-7187c760db69985124457decf7aa7997fa141fc0.zip
mail/xmail: Disable aslr
A segfault results when aslr is enabled. MFH: 2023Q3
-rw-r--r--mail/xmail/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/mail/xmail/Makefile b/mail/xmail/Makefile
index 092e307b2878..6ef875d83dfc 100644
--- a/mail/xmail/Makefile
+++ b/mail/xmail/Makefile
@@ -20,4 +20,7 @@ post-patch:
# Fix the build with -fno-common (for Clang 11 and GCC 10)
@${REINPLACE_CMD} -e '/In_Bogus_Mail_File;/d' ${WRKSRC}/xmail.c
+pre-install:
+ @${ELFCTL} -e +noaslr ${WRKSRC}/xmail
+
.include <bsd.port.mk>