aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-02-15 10:09:04 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-02-15 10:09:04 +0000
commit719f09fbfeabba82ba471afb004d08d8093ceee5 (patch)
treed1d046cbbc11fa9fbd641575b57d550600f9cd78
parentd39a4b86e21736268809502ec515370430990098 (diff)
downloadports-719f09fbfeabba82ba471afb004d08d8093ceee5.tar.gz
ports-719f09fbfeabba82ba471afb004d08d8093ceee5.zip
Try to quickly unbreak two of my ports against Clang 15
Reported by: pkg-fallout
-rw-r--r--lang/gnu-apl/Makefile1
-rw-r--r--sysutils/bsdfan/Makefile3
2 files changed, 4 insertions, 0 deletions
diff --git a/lang/gnu-apl/Makefile b/lang/gnu-apl/Makefile
index 38a5373eacf0..4b2691406369 100644
--- a/lang/gnu-apl/Makefile
+++ b/lang/gnu-apl/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3
USES= compiler:c++11-lang gmake libtool localbase
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CXX_WERROR=no
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/sysutils/bsdfan/Makefile b/sysutils/bsdfan/Makefile
index 39382652909a..2cb710a7b4d6 100644
--- a/sysutils/bsdfan/Makefile
+++ b/sysutils/bsdfan/Makefile
@@ -20,6 +20,9 @@ GH_TAGNAME= d8428a7
PLIST_FILES= bin/bsdfan man/man1/bsdfan.1.gz \
@sample\ etc/bsdfan.conf.sample
+post-patch:
+ @${REINPLACE_CMD} -e 's,getTemp(,&void,' ${WRKSRC}/system.c
+
post-install:
${INSTALL_DATA} ${WRKSRC}/bsdfan.conf \
${STAGEDIR}${PREFIX}/etc/bsdfan.conf.sample