aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 20:46:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 20:46:03 +0000
commit71bd5e9fb20e9aed2530bf54f6504da2ace88b26 (patch)
tree42c6e446dd048e4d50a577d921d1e16e2d83cb03
parent2c229f76432612f3f54ac687a5458d3fddd3a47a (diff)
downloadports-71bd5e9fb20e9aed2530bf54f6504da2ace88b26.tar.gz
ports-71bd5e9fb20e9aed2530bf54f6504da2ace88b26.zip
databases/py-queries: Allow build with py-psycopg2 2.9+
- Bump PORTREVISION for package change
-rw-r--r--databases/py-queries/Makefile3
-rw-r--r--databases/py-queries/files/patch-setup.py11
2 files changed, 13 insertions, 1 deletions
diff --git a/databases/py-queries/Makefile b/databases/py-queries/Makefile
index 8e772ca5df47..0bb320f365b8 100644
--- a/databases/py-queries/Makefile
+++ b/databases/py-queries/Makefile
@@ -2,6 +2,7 @@
PORTNAME= queries
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Simplified PostgreSQL client built upon Psycopg2
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.5.1<2.9:databases/py-psycopg2@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.5.1<3:databases/py-psycopg2@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/databases/py-queries/files/patch-setup.py b/databases/py-queries/files/patch-setup.py
new file mode 100644
index 000000000000..817559c5582e
--- /dev/null
+++ b/databases/py-queries/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-03-09 17:39:51 UTC
++++ setup.py
+@@ -7,7 +7,7 @@ import setuptools
+ if platform.python_implementation() == 'PyPy':
+ install_requires = ['psycopg2cffi>=2.7.2,<2.9']
+ else:
+- install_requires = ['psycopg2>=2.5.1,<2.9']
++ install_requires = ['psycopg2>=2.5.1,<3']
+
+ # Install tornado if generating docs on readthedocs
+ if os.environ.get('READTHEDOCS', None) == 'True':