aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-09-20 06:36:27 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-09-20 07:43:32 +0000
commit71f0f861cedf2a7ddcc0cc4909fc01f630453da8 (patch)
tree80d8aba899167edc85f4e13cc07f287e4ba70076
parent833240cfd41f88930975f886cdbed492ed9c2e75 (diff)
downloadports-71f0f861cedf2a7ddcc0cc4909fc01f630453da8.tar.gz
ports-71f0f861cedf2a7ddcc0cc4909fc01f630453da8.zip
irc/irssi: Fix build with ssl from ports
Building with ssl from ports used the headers from ports, but still linked the libs from base and therefore failed. Patch meson.build to look for OpenSSL libs in ${OPENSSLLIB} to fix this. Approved by: portmgr (blanket, build fix)
-rw-r--r--irc/irssi/Makefile3
-rw-r--r--irc/irssi/files/patch-meson.build12
2 files changed, 15 insertions, 0 deletions
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index db30aedfa747..b3db9f3aa2ae 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -41,6 +41,9 @@ UTF8PROC_MESON_NO= disable-utf8proc
PERL_USE_OFF= perl5=build
+post-patch:
+ @${REINPLACE_CMD} 's|%%OPENSSLLIB%%|${OPENSSLLIB}|' ${WRKSRC}/meson.build
+
post-install-PERL-off:
@${RM} -r ${STAGEDIR}${DATADIR}/scripts
diff --git a/irc/irssi/files/patch-meson.build b/irc/irssi/files/patch-meson.build
new file mode 100644
index 000000000000..722b7a6da6d2
--- /dev/null
+++ b/irc/irssi/files/patch-meson.build
@@ -0,0 +1,12 @@
+--- meson.build.orig 2023-03-28 12:13:26 UTC
++++ meson.build
+@@ -284,7 +284,8 @@ if glib_internal and want_static_dependency and want_f
+ else
+ openssl_dep = dependency('openssl', static : want_static_dependency, include_type : 'system')
+ endif
+-dep += openssl_dep
++dep += cc.find_library('crypto', dirs: '%%OPENSSLLIB%%')
++dep += cc.find_library('ssl', dirs: '%%OPENSSLLIB%%')
+
+ ############
+ # utf8proc #