aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2021-09-14 11:29:35 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2021-09-14 11:51:58 +0000
commit72629b6891c832e57808a0bdb686c2433951c546 (patch)
tree0780b4e6e1b4c212f2d8b1ada05c771a41af47d3
parent4225322c2a200c9c88fc82a34788e19e2aab98fb (diff)
downloadports-72629b6891c832e57808a0bdb686c2433951c546.tar.gz
ports-72629b6891c832e57808a0bdb686c2433951c546.zip
ports-mgmt/pkg-devel: Fix packaging from poudriere
If there is no pkg(8) installed in the jail/host pkg-static will be used but we don't have pkg-static with SAN so add a link in the WRKSRC. Also poudriere just extract pkg-static from the pkg archive so cp instead of symlink
-rw-r--r--ports-mgmt/pkg-devel/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/ports-mgmt/pkg-devel/Makefile b/ports-mgmt/pkg-devel/Makefile
index b59c13f584c5..4d6afe84ec23 100644
--- a/ports-mgmt/pkg-devel/Makefile
+++ b/ports-mgmt/pkg-devel/Makefile
@@ -71,13 +71,18 @@ post-patch:
${REINPLACE_CMD} -e "s|-llzma|${LIBLZMA_LIBS}|g" ${WRKSRC}/auto.def \
${WRKSRC}/src/Makefile.autosetup ${WRKSRC}/tests/Makefile.autosetup
+.if ${PORT_OPTIONS:MSAN}
+post-build:
+ @(cd ${WRKSRC}/src && \
+ ${LN} -fs pkg pkg-static)
+.endif
+
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/compat/pkg
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/NEWS
.if ${PORT_OPTIONS:MSAN}
- @(cd ${STAGEDIR}${PREFIX}/sbin/ && \
- ${LN} -fs pkg pkg-static)
+ @${CP} ${STAGEDIR}${PREFIX}/sbin/pkg ${STAGEDIR}${PREFIX}/sbin/pkg-static
.endif
.include <bsd.port.post.mk>