aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:45:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:03 +0000
commit72aa9c4e40442cf5cb59004fc0474d946599c888 (patch)
tree7868caf3dd049078c36ab5054928e840ab24249a
parent98dc75c98474271da38a049240dc0bc354301c33 (diff)
downloadports-72aa9c4e40442cf5cb59004fc0474d946599c888.tar.gz
ports-72aa9c4e40442cf5cb59004fc0474d946599c888.zip
devel/py-tempora: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-tempora/Makefile10
-rw-r--r--devel/py-tempora/files/setup.py3
2 files changed, 5 insertions, 8 deletions
diff --git a/devel/py-tempora/Makefile b/devel/py-tempora/Makefile
index ff132e82156b..4db1ff5aae62 100644
--- a/devel/py-tempora/Makefile
+++ b/devel/py-tempora/Makefile
@@ -1,5 +1,6 @@
PORTNAME= tempora
PORTVERSION= 5.2.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,16 +12,15 @@ WWW= https://github.com/jaraco/tempora
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco.functools>=1.20:devel/py-jaraco.functools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=0,1:devel/py-pytz@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.mk>
diff --git a/devel/py-tempora/files/setup.py b/devel/py-tempora/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-tempora/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()