aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-02-04 00:54:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-02-04 00:55:50 +0000
commit72fc3435551494eac1156dc422cf477ed3a656ea (patch)
tree9e6d9b35b2a15d2bd405de12fc577d7aaa5ca9dd
parent332680fcb2d9804c5ac02f2669dd080afd40fb53 (diff)
downloadports-72fc3435551494eac1156dc422cf477ed3a656ea.tar.gz
ports-72fc3435551494eac1156dc422cf477ed3a656ea.zip
audio/vst3sdk: Unbreak on 14 and 15
The code doesn't correctly detect the location of the C++ 'filesystem' header in the C++17 mode. This is now fixed by switching to C++20.
-rw-r--r--audio/vst3sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/vst3sdk/Makefile b/audio/vst3sdk/Makefile
index 68df5d8c0c00..b3efa1c5f5e4 100644
--- a/audio/vst3sdk/Makefile
+++ b/audio/vst3sdk/Makefile
@@ -12,7 +12,6 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BROKEN_i386= fails to build: static_assert failed due to requirement 'alignof(Steinberg::Vst::ProcessContext) == (0 ? 8U : 0 ? 1U : 1 ? 8U : 8U)
-BROKEN_FreeBSD_14= fails to compile: 'experimental/filesystem' file not found
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libexpat.so:textproc/expat2 \
@@ -27,6 +26,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
USES= cmake compiler:c++14-lang gnome localbase:ldflags pkgconfig shebangfix xorg
USE_GNOME= cairo gtk30 gtkmm30
USE_XORG= ice sm x11 xcb xext
+USE_CXXSTD= c++20 # otherwise the code in public.sdk/source/vst/hosting/module_linux.cpp uses the default value of __cplusplus=201703 and fails to use the correct #include <filesystem>
USE_GITHUB= yes
GH_ACCOUNT= steinbergmedia