aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Duchateau <duchateau.olivier@gmail.com>2022-06-29 05:38:36 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-06-30 05:33:07 +0000
commit732a765f6ffb302c2e16823d3eb74df12ddecf34 (patch)
tree36ce8bcb29877dd7027380c74018aecddc8399f9
parent45d354b961d7ad7224a3163c4bada8b9cd7d484e (diff)
downloadports-732a765f6ffb302c2e16823d3eb74df12ddecf34.tar.gz
ports-732a765f6ffb302c2e16823d3eb74df12ddecf34.zip
sysutils/bamf: update to 0.5.6
PR: 264203 Reported by: duchateau.olivier@gmail.com (maintainer)
-rw-r--r--sysutils/bamf/Makefile17
-rw-r--r--sysutils/bamf/distinfo6
-rw-r--r--sysutils/bamf/files/patch-configure31
-rw-r--r--sysutils/bamf/files/patch-tests_gtester2xunit.py27
4 files changed, 20 insertions, 61 deletions
diff --git a/sysutils/bamf/Makefile b/sysutils/bamf/Makefile
index 9753bcb76c26..cbb4b0959ec7 100644
--- a/sysutils/bamf/Makefile
+++ b/sysutils/bamf/Makefile
@@ -1,10 +1,7 @@
-# Created by: Olivier Duchateau
-
PORTNAME= bamf
-PORTVERSION= 0.5.4
+PORTVERSION= 0.5.6
CATEGORIES= sysutils
-MASTER_SITES= https://launchpadlibrarian.net/280921055/ \
- https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
+MASTER_SITES= https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
MAINTAINER= duchateau.olivier@gmail.com
COMMENT= BAMF Application Matching Framework
@@ -15,15 +12,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
BUILD_DEPENDS= vapigen:lang/vala \
${PYTHON_PKGNAMEPREFIX}lxml>=4.4.2:devel/py-lxml@${PY_FLAVOR}
LIB_DEPENDS= libgtop-2.0.so:devel/libgtop \
- libstartup-notification-1.so:x11/startup-notification
+ libstartup-notification-1.so:x11/startup-notification \
+ libharfbuzz.so:print/harfbuzz
USES= compiler:c11 gettext-runtime gmake gnome libtool pathfix \
- pkgconfig python:3.5+,build xorg
-GNU_CONFIGURE= yes
+ pkgconfig python:3.6+,build xorg
USE_GNOME= gtk30 glib20 introspection:build libwnck3 cairo gdkpixbuf2
USE_XORG= x11
-INSTALL_TARGET= install-strip
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-headless-tests \
--disable-gtktest \
--disable-gcov \
@@ -32,6 +29,8 @@ CONFIGURE_ARGS+=--disable-headless-tests \
--enable-export-actions-menu=no \
--enable-introspection=yes
+INSTALL_TARGET= install-strip
+
post-patch:
${REINPLACE_CMD} -e 's| -Wl,-Bsymbolic-functions||' \
${WRKSRC}/src/Makefile.in
diff --git a/sysutils/bamf/distinfo b/sysutils/bamf/distinfo
index dd62829c8271..208bd52ae988 100644
--- a/sysutils/bamf/distinfo
+++ b/sysutils/bamf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1579354448
-SHA256 (bamf-0.5.4.tar.gz) = 5bb87a5bf46ab1fc9a229a851c0ee4f610d943716a7c83d318f6a8f50d76beb3
-SIZE (bamf-0.5.4.tar.gz) = 638756
+TIMESTAMP = 1653398561
+SHA256 (bamf-0.5.6.tar.gz) = 4fcd00f23c542f3b79f35e10e322b67eacb399cac83f48db261cd8e8ea709478
+SIZE (bamf-0.5.6.tar.gz) = 638293
diff --git a/sysutils/bamf/files/patch-configure b/sysutils/bamf/files/patch-configure
index eaea4dd11aec..9fc3d1c0a7f0 100644
--- a/sysutils/bamf/files/patch-configure
+++ b/sysutils/bamf/files/patch-configure
@@ -1,24 +1,11 @@
---- configure.orig 2018-11-07 22:39:51 UTC
+--- configure.orig 2022-02-17 18:25:55 UTC
+++ configure
-@@ -14653,10 +14653,10 @@ fi
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for gtester2xunit dependencies" >&5
- $as_echo_n "checking for gtester2xunit dependencies... " >&6; }
--if !($PYTHON -c "import libxslt, libxml2" 2> /dev/null); then
-+if !($PYTHON -c "import lxml" 2> /dev/null); then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
- $as_echo "no" >&6; }
-- as_fn_error $? "You need to install python-libxslt1 and python-libxml2" "$LINENO" 5;
-+ as_fn_error $? "You need to install python-lxml" "$LINENO" 5;
+@@ -15473,7 +15473,7 @@ yes)
+ warning_flags="-wall -Wno-error=deprecated-declarations"
+ ;;
+ maximum|error)
+-warning_flags="-Wall -Wno-error=deprecated-declarations -Wempty-body -Wformat-security -Winit-self -Warray-bounds -Wimplicit-function-declaration"
++warning_flags="-Wall -Wno-error=deprecated-declarations -Warray-bounds -Wimplicit-function-declaration"
+ if test "$enable_compile_warnings" = "error" ; then
+ warning_flags="$warning_flags -Werror"
fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
- $as_echo "yes" >&6; }
-@@ -15374,7 +15374,7 @@ rm -f core conftest.err conftest.$ac_objext \
- rm -f conf.gtktest
-
-
--CFLAGS="$CFLAGS -Wall -Werror -Wno-error=deprecated-declarations -Wempty-body -Wformat-security -Winit-self -Warray-bounds -Wimplicit-function-declaration -lm"
-+CFLAGS="$CFLAGS -Wall -Winit-self -Warray-bounds -Wimplicit-function-declaration"
-
-
-
diff --git a/sysutils/bamf/files/patch-tests_gtester2xunit.py b/sysutils/bamf/files/patch-tests_gtester2xunit.py
deleted file mode 100644
index 585123a4e699..000000000000
--- a/sysutils/bamf/files/patch-tests_gtester2xunit.py
+++ /dev/null
@@ -1,27 +0,0 @@
---- tests/gtester2xunit.py.orig 2018-11-07 22:39:11 UTC
-+++ tests/gtester2xunit.py
-@@ -1,18 +1,17 @@
- #! /usr/bin/python
- from argparse import ArgumentParser
--import libxslt
--import libxml2
- import sys
- import os
-+from lxml import etree
-
- XSL_TRANSFORM='/usr/share/gtester2xunit/gtester.xsl'
-
- def transform_file(input_filename, output_filename, xsl_file):
-- gtester = libxml2.parseFile(xsl_file)
-- style = libxslt.parseStylesheetDoc(gtester)
-- doc = libxml2.parseFile(input_filename)
-- result = style.applyStylesheet(doc, None)
-- result.saveFormatFile(filename=output_filename, format=True)
-+ gtester = etree.parse(xsl_file)
-+ style = etree.XSLT(gtester)
-+ doc = etree.parse(input_filename)
-+ result = style(doc)
-+ result.write(filename=output_filename, format=True)
-
-
- def get_output_filename(input_filename):