aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2021-12-14 08:50:16 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2021-12-14 08:59:30 +0000
commit737ebcdfe26f82576af80a9de649d7607f2f97de (patch)
tree0775d6777c5f1058471e5b7e52c6965304958902
parent987d3f0023435e6aa88e3f9426d54911dadca1ab (diff)
downloadports-737ebcdfe26f82576af80a9de649d7607f2f97de.tar.gz
ports-737ebcdfe26f82576af80a9de649d7607f2f97de.zip
databases/couchdb3: depend on devel/icu
While CouchDB 3.2.1 switches a large portion of comparison functionality to internal erlang code, this is still required as a dependency for ejson_compare. devel/icu is an indirect dependency of spidermonkey but we should be specific and require it also. pet with portfmt while here.
-rw-r--r--databases/couchdb3/Makefile24
1 files changed, 14 insertions, 10 deletions
diff --git a/databases/couchdb3/Makefile b/databases/couchdb3/Makefile
index 95f3c8b36e7c..b59c414eefe2 100644
--- a/databases/couchdb3/Makefile
+++ b/databases/couchdb3/Makefile
@@ -1,5 +1,6 @@
PORTNAME= couchdb3
-DISTVERSION= 3.2.1
+PORTVERSION= 3.2.1
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= APACHE/couchdb/source/${DISTVERSION}
DISTNAME= apache-couchdb-${DISTVERSION}
@@ -7,12 +8,13 @@ DISTNAME= apache-couchdb-${DISTVERSION}
MAINTAINER= dch@FreeBSD.org
COMMENT= JSON document database with HTTP API and scalable multi-master sync
-LICENSE= APACHE20 BSD3CLAUSE ISCL WTFPL OFL11
+LICENSE= APACHE20 BSD3CLAUSE ISCL OFL11 WTFPL
LICENSE_COMB= multi
-BUILD_DEPENDS= rebar:devel/rebar \
- erlang-runtime${ERLVER}>=${ERLVER}.0:lang/erlang-runtime${ERLVER}
-LIB_DEPENDS= libmozjs-78.so:lang/spidermonkey78
+BUILD_DEPENDS= erlang-runtime${ERLVER}>=${ERLVER}.0:lang/erlang-runtime${ERLVER} \
+ rebar:devel/rebar
+LIB_DEPENDS= libicudata.so:devel/icu \
+ libmozjs-78.so:lang/spidermonkey78
RUN_DEPENDS= erlang-runtime${ERLVER}>=${ERLVER}.0:lang/erlang-runtime${ERLVER}
USES= compiler:c++17-lang cpe gmake libtool ncurses
@@ -35,7 +37,9 @@ SUB_LIST= APPDIR=${APPDIR} \
PLIST_SUB= VERSION=${DISTVERSION}
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --skip-deps --user ${USERS} --rebar ${LOCALBASE}/bin/rebar \
+CONFIGURE_ARGS= --skip-deps \
+ --user ${USERS} \
+ --rebar ${LOCALBASE}/bin/rebar \
--spidermonkey-version 78
ALL_TARGET= release
@@ -78,7 +82,7 @@ post-patch:
.endif
pre-install:
- # relocate user-modifiable runtime configs to match hier(7)
+# relocate user-modifiable runtime configs to match hier(7)
${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/rel/couchdb/etc/local.ini \
${STAGEDIR}${ETCDIR}/local.ini.sample
@@ -86,11 +90,11 @@ pre-install:
${STAGEDIR}${ETCDIR}/vm.args.sample
${INSTALL_MAN} ${WRKSRC}/share/docs/man/apachecouchdb.1 \
${STAGEDIR}${MANPREFIX}/man/man1
- # prune build artefacts and surplus headers
+# prune build artefacts and surplus headers
${FIND} -E ${WRKSRC} -type f \
-regex '.*\.(a|buildinfo|c|cc|cmd|d|o|orig|h|cpp)' -print -delete
@${CP} ${WRKSRC}/src/docs/images/favicon.ico ${WRKSRC}/share/www/
- # remove runtime dirs and files that were moved to match hier(7)
+# remove runtime dirs and files that were moved to match hier(7)
${RM} -rv \
${WRKSRC}/rel/couchdb/etc/*.d \
${WRKSRC}/rel/couchdb/etc/local.ini \
@@ -109,7 +113,7 @@ post-install:
@${MKDIR} \
${STAGEDIR}${DBDIR} \
${STAGEDIR}${LOGDIR}
- # fauxton UI is a required component
+# fauxton UI is a required component
(cd ${WRKSRC}/share/www && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
post-install-DOCS-on: