aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-08-02 13:21:36 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-08-02 20:57:44 +0000
commit73dcbdb9f040a873f83f8fadf575c998ac1988b9 (patch)
tree7e72413732fbd04ad399cd91455ebd0f66982882
parent89d4a86d37878b65eac4e61ca22afea0a3417fa4 (diff)
downloadports-73dcbdb9f040a873f83f8fadf575c998ac1988b9.tar.gz
ports-73dcbdb9f040a873f83f8fadf575c998ac1988b9.zip
sysutils/e2tools: Utilities to manipulate files in an ext2/ext3 filesystem
PR: 257561
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/e2tools/Makefile18
-rw-r--r--sysutils/e2tools/distinfo3
-rw-r--r--sysutils/e2tools/pkg-descr19
-rw-r--r--sysutils/e2tools/pkg-plist16
5 files changed, 57 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5521ca1406e7..26bed7a16f79 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -313,6 +313,7 @@
SUBDIR += dwatch-json
SUBDIR += dwatch-pwsnoop
SUBDIR += e2fsprogs
+ SUBDIR += e2tools
SUBDIR += ebsnvme-id
SUBDIR += ec2-scripts
SUBDIR += eclat
diff --git a/sysutils/e2tools/Makefile b/sysutils/e2tools/Makefile
new file mode 100644
index 000000000000..5e783fd2452e
--- /dev/null
+++ b/sysutils/e2tools/Makefile
@@ -0,0 +1,18 @@
+PORTNAME= e2tools
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.0
+CATEGORIES= sysutils
+
+MAINTAINER= fuz@fuz.su
+COMMENT= Utilities to manipulate files in an ext2/ext3 filesystem
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libext2fs.so:sysutils/e2fsprogs
+
+USES= autoreconf pkgconfig
+USE_GITHUB= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/e2tools/distinfo b/sysutils/e2tools/distinfo
new file mode 100644
index 000000000000..6b295d46fa4b
--- /dev/null
+++ b/sysutils/e2tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1627906885
+SHA256 (e2tools-e2tools-v0.1.0_GH0.tar.gz) = 5988f0f1f68ed69e0e89aa192dda650cf685cdb767b95fa4764be8c44127d97f
+SIZE (e2tools-e2tools-v0.1.0_GH0.tar.gz) = 94553
diff --git a/sysutils/e2tools/pkg-descr b/sysutils/e2tools/pkg-descr
new file mode 100644
index 000000000000..dd5df7e65bab
--- /dev/null
+++ b/sysutils/e2tools/pkg-descr
@@ -0,0 +1,19 @@
+e2tools is a simple set of GPL'ed utilities to read, write, and
+manipulate files in an ext2/ext3 filesystem. These utilities access a
+filesystem directly using the ext2fs library. I wrote these tools in
+order to copy files into a linux filesystem on a machine that does not
+have ext2 support. Of course, they can also be used on a Linux machine
+to read/write to disk images or floppies without having to mount them
+or have root access.
+
+Supported functionality:
+
+ - copy files: e2cp
+ - move files: e2mv
+ - remove files: e2rm
+ - create directory: e2mkdir
+ - create hard links: e2ln
+ - list files/directories: e2ls
+ - output the last part of a file: e2tail
+
+WWW: https://e2tools.github.io/
diff --git a/sysutils/e2tools/pkg-plist b/sysutils/e2tools/pkg-plist
new file mode 100644
index 000000000000..25cc55166508
--- /dev/null
+++ b/sysutils/e2tools/pkg-plist
@@ -0,0 +1,16 @@
+bin/e2cp
+bin/e2ln
+bin/e2ls
+bin/e2mkdir
+bin/e2mv
+bin/e2rm
+bin/e2tail
+bin/e2tools
+man/man1/e2cp.1.gz
+man/man1/e2ln.1.gz
+man/man1/e2ls.1.gz
+man/man1/e2mkdir.1.gz
+man/man1/e2mv.1.gz
+man/man1/e2rm.1.gz
+man/man1/e2tail.1.gz
+man/man7/e2tools.7.gz