aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 21:51:11 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:49 +0000
commit73ed226ab4b08daa82e2a8ba850f7978d9551f2e (patch)
tree79e4638bb6b2ea0c542aa01a466f08d2ffea9526
parent02ac12ab4347d0b8c512b99d6046e667f70558cb (diff)
downloadports-73ed226ab4b08daa82e2a8ba850f7978d9551f2e.tar.gz
ports-73ed226ab4b08daa82e2a8ba850f7978d9551f2e.zip
graphics/povray37: make compatible with OpenEXR/Imath 3.0
-rw-r--r--graphics/povray37/Makefile6
-rw-r--r--graphics/povray37/files/patch-source_backend_povray.cpp11
-rw-r--r--graphics/povray37/files/patch-unix_config_ax__check__openexr.m411
3 files changed, 25 insertions, 3 deletions
diff --git a/graphics/povray37/Makefile b/graphics/povray37/Makefile
index 972d9e052c02..aba7cd7e3667 100644
--- a/graphics/povray37/Makefile
+++ b/graphics/povray37/Makefile
@@ -1,7 +1,7 @@
PORTNAME= povray
DISTVERSIONPREFIX= v
DISTVERSION= 3.7.0.8
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
PKGNAMESUFFIX= 37
@@ -78,8 +78,8 @@ CONFIGURE_ARGS+=--without-libtiff
.if ${PORT_OPTIONS:MSTATIC}
BUILD_DEPENDS+= openexr>=1.6:graphics/openexr
.else
-LIB_DEPENDS+= libIlmImf.so:graphics/openexr
-CPPFLAGS+= -I${LOCALBASE}/include/OpenEXR
+LIB_DEPENDS+= libOpenEXR.so:graphics/openexr libImath.so:math/Imath
+CPPFLAGS+= -I${LOCALBASE}/include/OpenEXR -I${LOCALBASE}/include/Imath -DInt64=uint64_t
.endif
.else
CONFIGURE_ARGS+=--without-openexr
diff --git a/graphics/povray37/files/patch-source_backend_povray.cpp b/graphics/povray37/files/patch-source_backend_povray.cpp
new file mode 100644
index 000000000000..61bbaf34ab68
--- /dev/null
+++ b/graphics/povray37/files/patch-source_backend_povray.cpp
@@ -0,0 +1,11 @@
+--- source/backend/povray.cpp.orig 2018-05-27 09:54:06 UTC
++++ source/backend/povray.cpp
+@@ -68,7 +68,7 @@
+ extern "C" const char* TIFFGetVersion(void);
+ #endif
+ #ifndef OPENEXR_MISSING
+- #include <IlmBaseConfig.h>
++ #include <ImathConfig.h>
+ #include <OpenEXRConfig.h>
+ // NOTE:
+ // Versions of OpenEXR and IlmImf prior to 1.7.1 do not seem to have a way to get the version number,
diff --git a/graphics/povray37/files/patch-unix_config_ax__check__openexr.m4 b/graphics/povray37/files/patch-unix_config_ax__check__openexr.m4
new file mode 100644
index 000000000000..5bdd9b4deabf
--- /dev/null
+++ b/graphics/povray37/files/patch-unix_config_ax__check__openexr.m4
@@ -0,0 +1,11 @@
+--- unix/config/ax_check_openexr.m4.orig 2018-05-27 09:54:06 UTC
++++ unix/config/ax_check_openexr.m4
+@@ -56,7 +56,7 @@ AC_DEFUN([AX_CHECK_OPENEXR],
+ # check include file
+ AC_CHECK_HEADER(
+ [OpenEXR/ImfCRgbaFile.h],
+- [AC_CHECK_LIB([IlmImf], [ImfInputReadPixels], [], [ax_check_openexr="not found"])],
++ [AC_CHECK_LIB([OpenEXR], [ImfInputReadPixels], [], [ax_check_openexr="not found"])],
+ [ax_check_openexr="no headers"]
+ )
+ fi