aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-05-28 17:49:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-05-28 18:56:17 +0000
commit743c81d6e447fb36d012711161bc39e74352e3e8 (patch)
tree67eee9ea2dee35b203133819a99963eac638a888
parent65afc940ab591ce783c8a1c70f8326e03d9a64eb (diff)
downloadports-743c81d6e447fb36d012711161bc39e74352e3e8.tar.gz
ports-743c81d6e447fb36d012711161bc39e74352e3e8.zip
science/py-tensorflow: Enable the option JOBS_HALF in an attempt to fix build
Tensorflow build is killed on builders with signal 9 probably because it builds too long. With JOBS_HALF=ON it would use more CPUs and would build faster. Reported by: fallout
-rw-r--r--science/py-tensorflow/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/py-tensorflow/Makefile b/science/py-tensorflow/Makefile
index 11ff57256aaa..bc24f273ad1e 100644
--- a/science/py-tensorflow/Makefile
+++ b/science/py-tensorflow/Makefile
@@ -75,7 +75,7 @@ OPTIONS_DEFINE= CPU_OPTS XLA
OPTIONS_RADIO= PARALLEL_JOBS
OPTIONS_RADIO_PARALLEL_JOBS= JOBS_1 JOBS_HALF JOBS_ALL
PARALLEL_JOBS_DESC= How many jobs to run during build?
-OPTIONS_DEFAULT= JOBS_1
+OPTIONS_DEFAULT= JOBS_HALF
JOBS_1_DESC= Run one job
JOBS_1_VARS= TF_JOBS_NUMBER=1