aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-31 03:06:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-31 03:06:56 +0000
commit745b591b79cb457de8179a78119e289b51be1fda (patch)
tree151fae0f5a2958d669e689cd2a2b84be110c3996
parent381627efd72d91c8ff9b78fff14858996878e4e1 (diff)
downloadports-745b591b79cb457de8179a78119e289b51be1fda.tar.gz
ports-745b591b79cb457de8179a78119e289b51be1fda.zip
lang/py-lupa: Update to 2.1
-rw-r--r--lang/py-lupa/Makefile8
-rw-r--r--lang/py-lupa/distinfo6
-rw-r--r--lang/py-lupa/files/patch-lupa-tests-test.py14
-rw-r--r--lang/py-lupa/files/patch-setup.py28
4 files changed, 9 insertions, 47 deletions
diff --git a/lang/py-lupa/Makefile b/lang/py-lupa/Makefile
index c49dcfcdd6b4..212b959efcd5 100644
--- a/lang/py-lupa/Makefile
+++ b/lang/py-lupa/Makefile
@@ -1,5 +1,5 @@
PORTNAME= lupa
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= lang python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +11,12 @@ WWW= https://github.com/scoder/lupa
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython3>=3.0.9:lang/cython3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= lua pkgconfig python
-USE_PYTHON= autoplist concurrent cython distutils unittest
+USE_PYTHON= autoplist concurrent pep517 unittest
MAKE_ARGS= --no-bundle --with-cython --with-lua-checks
TEST_ARGS= lupa.tests.test
diff --git a/lang/py-lupa/distinfo b/lang/py-lupa/distinfo
index 3a6e93a8477a..00f9289caadc 100644
--- a/lang/py-lupa/distinfo
+++ b/lang/py-lupa/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1684104502
-SHA256 (lupa-2.0.tar.gz) = ad3fef486be7adddd349fe9a9c393789061312cf98ebc533b489be34f484cb79
-SIZE (lupa-2.0.tar.gz) = 6278066
+TIMESTAMP = 1711466198
+SHA256 (lupa-2.1.tar.gz) = 760030712d5273396f5e963dd8731aefb5ac65d92eff8bf8fd4124c1630fe950
+SIZE (lupa-2.1.tar.gz) = 7111959
diff --git a/lang/py-lupa/files/patch-lupa-tests-test.py b/lang/py-lupa/files/patch-lupa-tests-test.py
deleted file mode 100644
index e55fbee71c13..000000000000
--- a/lang/py-lupa/files/patch-lupa-tests-test.py
+++ /dev/null
@@ -1,14 +0,0 @@
-Obtained from: https://github.com/scoder/lupa/commit/9fecb31fd368043699b8a88310f2718858b18a5f
-
---- lupa/tests/test.py.orig 2023-04-04 07:12:27 UTC
-+++ lupa/tests/test.py
-@@ -52,6 +52,9 @@ class TestLuaRuntimeRefcounting(LupaTestCase):
- if off_by_one and old_count == new_count + 1:
- # FIXME: This happens in test_attrgetter_refcycle - need to investigate why!
- self.assertEqual(old_count, new_count + 1)
-+ elif off_by_one and old_count == new_count + 2 and sys.version_info >= (3,11):
-+ # FIXME: This happens in test_attrgetter_refcycle - need to investigate why!
-+ self.assertEqual(old_count, new_count + 2)
- else:
- self.assertEqual(old_count, new_count)
-
diff --git a/lang/py-lupa/files/patch-setup.py b/lang/py-lupa/files/patch-setup.py
deleted file mode 100644
index 24288085b463..000000000000
--- a/lang/py-lupa/files/patch-setup.py
+++ /dev/null
@@ -1,28 +0,0 @@
-Obtained from: https://github.com/scoder/lupa/commit/19279acda1ad7e7a536adafe399b183701287bc1
-
---- setup.py.orig 2023-04-04 07:12:27 UTC
-+++ setup.py
-@@ -365,10 +365,11 @@ if not configs and not option_no_bundle:
- or (get_machine() != "x86_64" and 'luajit' in os.path.basename(lua_bundle_path.rstrip(os.sep)))
- )
- ]
--if not configs and not option_use_bundle:
-- configs = find_lua_build(no_luajit=option_no_luajit)
- if not configs:
-- configs = no_lua_error()
-+ configs = [
-+ (find_lua_build(no_luajit=option_no_luajit) if not option_use_bundle else {})
-+ or no_lua_error()
-+ ]
-
-
- # check if Cython is installed, and use it if requested or necessary
-@@ -484,7 +485,7 @@ setup(
- ],
-
- packages=['lupa'],
-- build_requires=['Cython>=0.29.28'],
-+ setup_requires=['Cython>=0.29.28'],
- ext_modules=ext_modules,
- libraries=ext_libraries,
- **extra_setup_args