aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-08-19 06:31:49 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-08-19 06:31:49 +0000
commit7461a3c2018beac3b809db6e1849ba96080088c2 (patch)
tree40ae3253c1303cf81ab7e21bab80dc4227be9eee
parent9ff864cb14876ee8dba7900e3afb7169e449b5f4 (diff)
downloadports-7461a3c2018beac3b809db6e1849ba96080088c2.tar.gz
ports-7461a3c2018beac3b809db6e1849ba96080088c2.zip
emulators/wine-devel: Update to Wine 6.15
This includes the following changes: - WinSock (WS2_32) library converted to PE. - Support for performance data in the registry. - More 32->64-bit thunks for NTDLL calls. - Improved floating point status handling in the C runtime. - More preparation work for the GDI syscall interface. - Various bug fixes. My patch files/patch-dlls-ntdll-unix-virtual.c has been accepted upstream in the meantime, so remove it here.
-rw-r--r--emulators/wine-devel/Makefile3
-rw-r--r--emulators/wine-devel/distinfo10
-rw-r--r--emulators/wine-devel/files/patch-dlls-ntdll-unix-virtual.c68
-rw-r--r--emulators/wine-devel/pkg-plist5
4 files changed, 10 insertions, 76 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index f2ba4d0e64c2..9d4d9a746b57 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -1,8 +1,7 @@
# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
PORTNAME= wine
-DISTVERSION= 6.14
-PORTREVISION= 2
+DISTVERSION= 6.15
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index ebf8d4d111d3..8b5354109fc8 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1627722537
-SHA256 (wine-6.14.tar.xz) = 64b471939943bc08e351027db6fbc2465c139650a3bffeb91657ff0ee8c25202
-SIZE (wine-6.14.tar.xz) = 24721316
-SHA256 (v6.14.tar.gz) = 4792d3d083af6f9b9b9239df7c3b0e344ebe0cf947b689bde97a67bf37d116e4
-SIZE (v6.14.tar.gz) = 9658088
+TIMESTAMP = 1629013007
+SHA256 (wine-6.15.tar.xz) = 61fd65a365832a62bae7a78429270c076fb2a29f1c7f462595d1f3543651779b
+SIZE (wine-6.15.tar.xz) = 24751680
+SHA256 (v6.15.tar.gz) = 8eab77df53dac69cc6ffd2df94e4b53f4312806649e2a27ea97082047fe7dd61
+SIZE (v6.15.tar.gz) = 9654539
diff --git a/emulators/wine-devel/files/patch-dlls-ntdll-unix-virtual.c b/emulators/wine-devel/files/patch-dlls-ntdll-unix-virtual.c
deleted file mode 100644
index 125e0908dcc6..000000000000
--- a/emulators/wine-devel/files/patch-dlls-ntdll-unix-virtual.c
+++ /dev/null
@@ -1,68 +0,0 @@
-commit 59da79021a6e441e3b21b933c744aba922208ec1
-Author: Gerald Pfeifer <gerald@pfeifer.com>
-Date: Tue Aug 10 22:36:27 2021 +0200
-
- ntdll: Only use sysinfo function when present.
-
- On some systems <sys/sysinfo.h> may be present while the sysinfo
- function may not, or at least not as part of standard libraries,
- so check whether the function is actually available before using
- it.
-
- This fixes builds on FreeBSD with the devel/libsysinfo present.
-
- Signed-off-by: Gerald Pfeifer <gerald@pfeifer.com>
- Signed-off-by: Alexandre Julliard <julliard@winehq.org>
-
-diff --git a/configure b/configure
-index 1be0aa9d217..e8c1cb9e3a8 100755
---- configure
-+++ configure
-@@ -18068,6 +18068,7 @@ for ac_func in \
- setprogname \
- sigprocmask \
- symlink \
-+ sysinfo \
- tcdrain \
- thr_kill2
-
-diff --git a/configure.ac b/configure.ac
-index 69e27147088..065b3f231bf 100644
---- configure.ac
-+++ configure.ac
-@@ -2205,6 +2205,7 @@ AC_CHECK_FUNCS(\
- setprogname \
- sigprocmask \
- symlink \
-+ sysinfo \
- tcdrain \
- thr_kill2
- )
-diff --git a/dlls/ntdll/unix/virtual.c b/dlls/ntdll/unix/virtual.c
-index a252e25fbc6..2cca90ac952 100644
---- dlls/ntdll/unix/virtual.c
-+++ dlls/ntdll/unix/virtual.c
-@@ -2737,7 +2737,8 @@ ULONG_PTR get_system_affinity_mask(void)
- */
- void virtual_get_system_info( SYSTEM_BASIC_INFORMATION *info, BOOL wow64 )
- {
--#if defined(HAVE_STRUCT_SYSINFO_TOTALRAM) && defined(HAVE_STRUCT_SYSINFO_MEM_UNIT)
-+#if defined(HAVE_SYSINFO) \
-+ && defined(HAVE_STRUCT_SYSINFO_TOTALRAM) && defined(HAVE_STRUCT_SYSINFO_MEM_UNIT)
- struct sysinfo sinfo;
-
- if (!sysinfo(&sinfo))
-diff --git a/include/config.h.in b/include/config.h.in
-index ad770281471..24f7b64ffd3 100644
---- include/config.h.in
-+++ include/config.h.in
-@@ -744,6 +744,9 @@
- /* Define to 1 if you have the <syscall.h> header file. */
- #undef HAVE_SYSCALL_H
-
-+/* Define to 1 if you have the `sysinfo' function. */
-+#undef HAVE_SYSINFO
-+
- /* Define to 1 if you have the
- <SystemConfiguration/SCDynamicStoreCopyDHCPInfo.h> header file. */
- #undef HAVE_SYSTEMCONFIGURATION_SCDYNAMICSTORECOPYDHCPINFO_H
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 96465de30124..e8d020d66f22 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -286,7 +286,6 @@ include/wine/windows/d3dvec.inl
include/wine/windows/d3dx10.h
include/wine/windows/d3dx10async.h
include/wine/windows/d3dx10core.h
-include/wine/windows/d3dx10core.idl
include/wine/windows/d3dx10math.h
include/wine/windows/d3dx10tex.h
include/wine/windows/d3dx11.h
@@ -972,6 +971,7 @@ include/wine/windows/wincred.h
include/wine/windows/wincrypt.h
include/wine/windows/windef.h
include/wine/windows/windns.h
+include/wine/windows/windot11.h
include/wine/windows/windows.foundation.collections.h
include/wine/windows/windows.foundation.collections.idl
include/wine/windows/windows.foundation.h
@@ -1551,6 +1551,7 @@ lib/wine/%%WINEARCH%%-unix/dxdiagn.dll.so
lib/wine/%%WINEARCH%%-unix/dxgi.dll.so
%%STAGING%%lib/wine/%%WINEARCH%%-unix/dxgkrnl.sys.so
%%STAGING%%lib/wine/%%WINEARCH%%-unix/dxgmms1.sys.so
+lib/wine/%%WINEARCH%%-unix/dxtrans.dll.so
lib/wine/%%WINEARCH%%-unix/dxva2.dll.so
lib/wine/%%WINEARCH%%-unix/eject.exe.so
lib/wine/%%WINEARCH%%-unix/esent.dll.so
@@ -2327,6 +2328,7 @@ lib/wine/%%WINEARCH%%-unix/wpcap.dll.so
lib/wine/%%WINEARCH%%-unix/wpcap.so
lib/wine/%%WINEARCH%%-unix/write.exe.so
lib/wine/%%WINEARCH%%-unix/ws2_32.dll.so
+lib/wine/%%WINEARCH%%-unix/ws2_32.so
lib/wine/%%WINEARCH%%-unix/wscript.exe.so
lib/wine/%%WINEARCH%%-unix/wsdapi.dll.so
lib/wine/%%WINEARCH%%-unix/wshom.ocx.so
@@ -2800,6 +2802,7 @@ lib/wine/%%WINEARCH%%-windows/dxdiagn.dll
lib/wine/%%WINEARCH%%-windows/dxgi.dll
%%STAGING%%lib/wine/%%WINEARCH%%-windows/dxgkrnl.sys
%%STAGING%%lib/wine/%%WINEARCH%%-windows/dxgmms1.sys
+lib/wine/%%WINEARCH%%-windows/dxtrans.dll
lib/wine/%%WINEARCH%%-windows/dxva2.dll
lib/wine/%%WINEARCH%%-windows/eject.exe
lib/wine/%%WINEARCH%%-windows/esent.dll