aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2021-04-14 12:37:09 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2021-04-14 12:37:09 +0000
commit750a7aee3b08f4fededd76a75dfe36c438227399 (patch)
tree17aa2d9d5a09820142496cbf0041f901980ba05b
parent0c92616098ffad32337d5b5e53e38ab4438c2b40 (diff)
downloadports-750a7aee3b08f4fededd76a75dfe36c438227399.tar.gz
ports-750a7aee3b08f4fededd76a75dfe36c438227399.zip
www/py-http-parser: re-add removed port
-rw-r--r--MOVED1
-rw-r--r--www/Makefile1
-rw-r--r--www/py-http-parser/Makefile25
-rw-r--r--www/py-http-parser/distinfo2
-rw-r--r--www/py-http-parser/pkg-descr5
5 files changed, 33 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 6446b415827b..8fbe233fd1a0 100644
--- a/MOVED
+++ b/MOVED
@@ -13915,7 +13915,6 @@ www/ljdump||2020-01-27|Has expired: Unmaintained, uses EOLed python27
www/monast||2020-01-27|Has expired: Unmaintained, uses EOLed python27
www/py-django-paging||2020-01-27|Has expired: Unmaintained, uses EOLed python27
www/py-fcgi||2020-01-27|Has expired: Unmaintained, uses EOLed python27
-www/py-http-parser||2020-01-27|Has expired: Unmaintained, uses EOLed python27
www/py-meld||2020-01-27|Has expired: Unmaintained, uses EOLed python27
www/py-mt||2020-01-27|Has expired: Unmaintained, uses EOLed python27
www/py-rhodecode||2020-01-27|Has expired: Unmaintained, uses EOLed python27
diff --git a/www/Makefile b/www/Makefile
index bc23553302fa..7c26afb37097 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1635,6 +1635,7 @@
SUBDIR += py-html5-parser
SUBDIR += py-html5lib
SUBDIR += py-httmock
+ SUBDIR += py-http-parser
SUBDIR += py-httpbin
SUBDIR += py-httpcore
SUBDIR += py-httpie
diff --git a/www/py-http-parser/Makefile b/www/py-http-parser/Makefile
new file mode 100644
index 000000000000..7ab9c564847a
--- /dev/null
+++ b/www/py-http-parser/Makefile
@@ -0,0 +1,25 @@
+# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= http-parser
+PORTVERSION= 0.8.3
+CATEGORIES= www
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= HTTP request/response parser for python in C
+
+DEPRECATED= Unmaintained, uses EOLed python27
+EXPIRATION_DATE= 2020-01-27
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:-3.6
+USE_PYTHON= autoplist distutils
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/http_parser/parser.so
+
+.include <bsd.port.mk>
diff --git a/www/py-http-parser/distinfo b/www/py-http-parser/distinfo
new file mode 100644
index 000000000000..c1dbca95893e
--- /dev/null
+++ b/www/py-http-parser/distinfo
@@ -0,0 +1,2 @@
+SHA256 (http-parser-0.8.3.tar.gz) = e2aff90a60def3e476bd71694d8757c0f95ebf2fedf0a8ae34ee306e0b20db83
+SIZE (http-parser-0.8.3.tar.gz) = 83040
diff --git a/www/py-http-parser/pkg-descr b/www/py-http-parser/pkg-descr
new file mode 100644
index 000000000000..6352f28069a7
--- /dev/null
+++ b/www/py-http-parser/pkg-descr
@@ -0,0 +1,5 @@
+HTTP request/response parser for Python compatible with Python 2.x (>=2.6),
+Python 3 and Pypy. If possible a C parser based on http-parser
+from Ryan Dahl will be used.
+
+WWW: https://github.com/benoitc/http-parser/