aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2024-04-09 06:26:41 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2024-04-09 06:36:33 +0000
commit754b2ef182b8622b129c78bd86993393f40345a0 (patch)
tree79d02c96c20989c012d67591105ac71c85d06beb
parentb884c7812e68a7c2bd939a9e4faaff38cbccd0a7 (diff)
downloadports-754b2ef182b8622b129c78bd86993393f40345a0.tar.gz
ports-754b2ef182b8622b129c78bd86993393f40345a0.zip
Mk/Uses/tcl.mk: remove support for Tcl/Tk 8.5
In preparation for removing the lang/tcl85 and x11-toolkits/tk85 ports. The 8.5 series is EOL. PR: 278098 Approved by: antoine (portmgr, exp-run)
-rw-r--r--Mk/Uses/tcl.mk19
-rw-r--r--lang/tclX/Makefile5
-rw-r--r--lang/tclX/files/tcl85-test-patch134
-rw-r--r--x11-toolkits/tk85/Makefile10
4 files changed, 13 insertions, 155 deletions
diff --git a/Mk/Uses/tcl.mk b/Mk/Uses/tcl.mk
index d940b4a19409..eb47dfea7bbf 100644
--- a/Mk/Uses/tcl.mk
+++ b/Mk/Uses/tcl.mk
@@ -38,11 +38,11 @@
# is installed, bring in the default version. See
# ${_TCLTK_DEFAULT_VERSION} below.
#
-# - 85, 86, 87 - Depend on a specific version series of PORT. Multiple
+# - 86, 87 - Depend on a specific version series of PORT. Multiple
# values are OK. The highest version available is
# picked.
#
-# - 85+, 86+, 87+ - Depend on any installed version greater or equal to
+# - 86+, 87+ - Depend on any installed version greater or equal to
# the specified version.
#
# If wrapper is specified, an additional dependency on tcl-wrapper or
@@ -71,7 +71,7 @@ _INCLUDE_USES_TCL_MK= yes
#
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
-_TCLTK_VALID_VERSIONS= 85 86 87
+_TCLTK_VALID_VERSIONS= 86 87
#
# Bring in the default and check that the specified version is in the list of
@@ -94,16 +94,13 @@ _TCLTK_PORT?= tcl
. if ${tcl_ARGS:M*+}
_TCLTK_MIN_VERSION:= ${tcl_ARGS:M*+:S/+//}
_TCLTK_WANTED_VERSIONS:=${_TCLTK_DEFAULT_VERSION}
-. if ${_TCLTK_MIN_VERSION} == "85"
-IGNORE= Minimum tcltk version 85+ is meaningless
-. endif
. endif
#
# Parse one or more ver arguments.
#
-. if ${tcl_ARGS:M8[5-7]}
-_TCLTK_WANTED_VERSIONS:=${tcl_ARGS:M8[5-7]}
+. if ${tcl_ARGS:M8[6-7]}
+_TCLTK_WANTED_VERSIONS:=${tcl_ARGS:M8[6-7]}
. endif
#
@@ -156,12 +153,6 @@ _TCLTK_WANTED_VERSION:= ${_TCLTK_HIGHEST_VERSION}
. endif
#
-# Deprecate by default all ports depending on 8.5
-. if ${_TCLTK_WANTED_VERSION} == "85"
-DEPRECATED= Tcl/Tk 8.5 is nearing EOL, please consider porting to Tcl/Tk 8.6
-. endif
-
-#
# Exported variables
#
TCL_VER:= ${_TCLTK_WANTED_VERSION:S/8/8./}
diff --git a/lang/tclX/Makefile b/lang/tclX/Makefile
index 634ea40236bb..9b667a83cc18 100644
--- a/lang/tclX/Makefile
+++ b/lang/tclX/Makefile
@@ -33,12 +33,7 @@ TCLM4= tcl.m4?name=2e84c8
.include <bsd.port.pre.mk>
-.if ${TCL_VER} > 8.4
-EXTRA_PATCHES+= ${FILESDIR}/tcl85-test-patch
-.endif
-.if ${TCL_VER} > 8.5
EXTRA_PATCHES+= ${FILESDIR}/tcl86-test-patch
-.endif
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/${TCLM4} ${WRKSRC}/tclconfig/tcl.m4
diff --git a/lang/tclX/files/tcl85-test-patch b/lang/tclX/files/tcl85-test-patch
deleted file mode 100644
index cfd07de15ec8..000000000000
--- a/lang/tclX/files/tcl85-test-patch
+++ /dev/null
@@ -1,134 +0,0 @@
-The half-baked set of hunks attempts to chase the wording-changes,
-that Tcl-8.5 has compared to the earlier releases. It allows TclX
-to pass self-tests, when compiled against Tcl-8.5, but is not
-suitable for merging into TclX' own tree.
-
-Someone with enough time to make the tests work with all supported
-Tcl-versions, should still do that...
-
- -mi
-
---- tests/cmdtrace.test 2005-11-17 19:01:35.000000000 -0500
-+++ tests/cmdtrace.test 2009-10-13 18:11:52.000000000 -0400
-@@ -92,5 +92,5 @@
- cmdtrace off
- GetTrace $cmdtraceFH
--} 0 "DoStuff4\\n
-+} 0 "DoStuff4
- DoStuff3
- DoStuff2
-@@ -103,5 +103,5 @@
- if {\$wap} {\\n set wap 0\\n } else \{\\n set wap 1...
- set wap 0
--cmdtrace off\\n
-+cmdtrace off
- "
-
-@@ -132,5 +132,5 @@
- cmdtrace off
- GetTrace $cmdtraceFH
--} 0 {DoStuff4\n
-+} 0 {DoStuff4
- DoStuff3
- DoStuff2
-@@ -143,5 +143,5 @@
- if {$wap} {\n set wap 0\n } else {\n set wap 1\n }
- set wap 0
--cmdtrace off\n
-+cmdtrace off
- }
-
-@@ -188,6 +188,5 @@
- lappend traceout $errorInfo $errorCode
- set traceout
--} 0 [list {CD {{DoStuff4
--}} DoStuff4 {}} \
-+} 0 [list {CD DoStuff4 DoStuff4 {}} \
- {CD DoStuff3 DoStuff3 {}} \
- {CD DoStuff2 DoStuff2 {}} \
-@@ -208,6 +207,5 @@
- }}} {}} \
- {CD {{set wap 0}} {{set wap 0}} {}} \
--{CD {{cmdtrace off
--}} {{cmdtrace off}} {}}\
-+{CD {{cmdtrace off}} {{cmdtrace off}} {}}\
- ERRORINFO \
- ERRORCODE]
---- tests/string.test 2002-09-25 20:19:02.000000000 -0400
-+++ tests/string.test 2009-10-13 18:25:03.000000000 -0400
-@@ -47,9 +47,18 @@
- } 0 {E}
-
-+switch $tcl_version {
-+8.3 {
-+ set anticipate "syntax error in expression \"4x-3\""
-+} 8.4 {
-+ set anticipate "syntax error in expression \"4x-3\": extra tokens at end of expression"
-+} default {
-+ set anticipate {invalid bareword "4x"
-+in expression "4x-3";
-+should be "$4x" or "{4x}" or "4x(...)" or ...}
-+}}
-+
- Test string-1.7 {cindex tests} {
-- cindex ABCDEFG lenx-3
--} 1 "syntax error in expression \"7x-3\"[expr {
-- ($tcl_version>8.3) ? ": extra tokens at end of expression" : ""
--}]"
-+ cindex ABCD lenx-3
-+} 1 $anticipate
-
- Test string-1.8 {cindex tests} {
-@@ -146,7 +156,5 @@
- # 8.4+ enhanced the error return from expressions
- crange ABCD lenx-3 end-1
--} 1 "syntax error in expression \"4x-3\"[expr {
-- ($tcl_version>8.3) ? ": extra tokens at end of expression" : ""
--}]"
-+} 1 $anticipate
-
- Test string-3.9 {crange tests} {
---- tests/tryeval.test 2002-04-04 01:10:30.000000000 -0500
-+++ tests/tryeval.test 2009-10-13 18:31:28.000000000 -0400
-@@ -110,10 +110,10 @@
- global final
- concat $result $final
--} {1 {cont: try_eval error 3.1} {cont: errorInfo-error-3.1
-- invoked from within
-+} {1 {cont: try_eval error 3.1} {cont: try_eval error 3.1
-+ while executing
- "try_eval $code $catch $finally"
- (procedure "test_try_eval" line 2)
- invoked from within
--"test_try_eval $code $catch $finally"} {cont: errorCode-error-3.1} finally-3.1}
-+"test_try_eval $code $catch $finally"} NONE finally-3.1}
-
-
-@@ -148,10 +148,10 @@
- global final
- concat $result $final
--} {1 {try_eval error 3.3} {errorInfo-error-3.3
-- invoked from within
-+} {1 {try_eval error 3.3} {try_eval error 3.3
-+ while executing
- "try_eval $code $catch $finally"
- (procedure "test_try_eval" line 2)
- invoked from within
--"test_try_eval $code $catch $finally"} errorCode-error-3.3 finally-3.3}
-+"test_try_eval $code $catch $finally"} NONE finally-3.3}
-
- test try_eval-3.4 {try_eval error result} {
-@@ -168,10 +168,10 @@
- global final
- list $result $final
--} {{1 {try_eval error 3.4} {errorInfo-error-3.4
-- invoked from within
-+} {{1 {try_eval error 3.4} {try_eval error 3.4
-+ while executing
- "try_eval $code $catch $finally"
- (procedure "test_try_eval" line 2)
- invoked from within
--"test_try_eval $code $catch $finally"} errorCode-error-3.4} finally-3.4}
-+"test_try_eval $code $catch $finally"} NONE} finally-3.4}
-
-
diff --git a/x11-toolkits/tk85/Makefile b/x11-toolkits/tk85/Makefile
index 0a4ca9522eb9..72130c149f77 100644
--- a/x11-toolkits/tk85/Makefile
+++ b/x11-toolkits/tk85/Makefile
@@ -17,14 +17,20 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
DEPRECATED= Tcl/Tk 8.5 is nearing EOL, please consider switching to Tcl/Tk 8.6
-USES+= tcl:${SHORT_TK_VER},tea xorg
+LIB_DEPENDS= libtcl${SHORT_TK_VER}.so:lang/tcl${SHORT_TK_VER}
+
+GNU_CONFIGURE= yes
+USES+= xorg display
USE_XORG= x11 xft xscrnsaver
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}/unix
TK_VER= ${PORTVERSION:R}
SHORT_TK_VER= ${TK_VER:S/.//}
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
-CONFIGURE_ARGS= --enable-xss \
+CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
+ --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --with-tclinclude=${LOCALBASE}/include/tcl${TK_VER} \
+ --enable-xss \
--enable-xft \
--enable-man-suffix=.${MAN_SUFFIX} \
--includedir=${PREFIX}/include/tk${TK_VER}