aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-09-25 21:27:08 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-09-25 21:27:08 +0000
commit761dc8a9f4ddef2adad122a57a477e65457582fb (patch)
tree3cda1ee1dbebc845c87d7f0406488b375f0c26c1
parentbe9289385619bb0fc3a41f06397dd08df7c7e3ee (diff)
downloadports-761dc8a9f4ddef2adad122a57a477e65457582fb.tar.gz
ports-761dc8a9f4ddef2adad122a57a477e65457582fb.zip
net/py-urllib3: disable SSL by default
The [secure] extra (provided by the SSL option) is deprecated: https://github.com/urllib3/urllib3/issues/2680 ...but the pyOpenSSL bit is un-deprecated: https://github.com/urllib3/urllib3/issues/3126 Given that even pyOpenSSL is regarded as an optional third-party module, disable by default. By side effect, reduces build load, induced by mainline py-cryptography's required Rust code, for those ports using sphinx to build documentation, as this is part of sphinx's dependency tree.
-rw-r--r--net/py-urllib3/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/py-urllib3/Makefile b/net/py-urllib3/Makefile
index 8d1148d22a44..e4cb36bc83c4 100644
--- a/net/py-urllib3/Makefile
+++ b/net/py-urllib3/Makefile
@@ -1,5 +1,6 @@
PORTNAME= urllib3
PORTVERSION= 1.26.16
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net python
MASTER_SITES= PYPI \
@@ -35,7 +36,7 @@ PYTEST_IGNORED_TESTS= test_ssl_read_timeout
SUB_FILES= pkg-message
OPTIONS_DEFINE= BROTLI SOCKS SSL
-OPTIONS_DEFAULT=SOCKS SSL
+OPTIONS_DEFAULT=SOCKS
BROTLI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}brotli>=1.0.9:archivers/py-brotli@${PY_FLAVOR}
SOCKS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pysocks>=1.5.6<2.0:net/py-pysocks@${PY_FLAVOR}